Closed Bug 1833031 Opened 11 months ago Closed 2 months ago

Address book filter (search) interferes with editing and access to contacts

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 102
Unspecified
All
defect

Tracking

(thunderbird_esr102 wontfix, thunderbird_esr115? fixed, thunderbird117 wontfix, thunderbird124? wontfix)

VERIFIED FIXED
125 Branch
Tracking Status
thunderbird_esr102 --- wontfix
thunderbird_esr115 ? fixed
thunderbird117 --- wontfix
thunderbird124 ? wontfix

People

(Reporter: wsmwk, Assigned: welpy-cw)

Details

(Keywords: regression)

Attachments

(2 files)

Example 1

#1. In address book window, type zzz into the search field
#2. edit > find > search addresses
#3. enter critera to find an existing contact
#4. select a contact and click properties
Result: "No contacts found". Contact is not opened. If you remove step 1 it works

Example 2

#1. In address book window, type zzz into the search field
#2. in message list select a message whose contact exists in an address book
#3. click on contact to or from in message pane, and pick edit contact
Result: empty contact is presented. If you remove step 1 it works

Need to test on 102, but I'd expect it to reproduce there

Flags: needinfo?(vseerror)
Version: Thunderbird 114 → Thunderbird 102

Example 1 doesn't behave the same in 102, but that no longer matters.
Example 2 still reproduces in 117 beta.

It's annoying but an uncommon scenario and easily worked around, so S4

Severity: -- → S4
Flags: needinfo?(vseerror)
OS: Unspecified → All
Assignee: nobody → h.w.forms
Attachment #9389213 - Attachment description: WIP: Bug 1833031 - Clear address book search view in commands for displaying/editing contacts. → Bug 1833031 - Clear address book search view in commands for displaying/editing contacts. r=#thunderbird-reviewers
Status: NEW → ASSIGNED
Target Milestone: --- → 125 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/75e041cf333a
Clear address book search view in commands for displaying/editing contacts. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

I confirm this allows edit to work on nightly using the specified steps. But it does clear the user's search field entry, so I would consider this to be a workaround patch.

(In reply to Wayne Mery (:wsmwk) from comment #5)

I confirm this allows edit to work on nightly using the specified steps. But it does clear the user's search field entry, so I would consider this to be a workaround patch.

Yes, I understand that, but I suspect that a real solution would require architectural changes in the address book component ...

Comment on attachment 9389213 [details]
Bug 1833031 - Clear address book search view in commands for displaying/editing contacts. r=#thunderbird-reviewers

[Approval Request Comment]
User impact if declined: see bug report
Testing completed (on c-c, etc.): yes
Risk to taking this patch (and alternatives if risky): low

Attachment #9389213 - Flags: approval-comm-esr115?

I can verify this works in nightly and beta.

Status: RESOLVED → VERIFIED

Comment on attachment 9389213 [details]
Bug 1833031 - Clear address book search view in commands for displaying/editing contacts. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9389213 - Flags: approval-comm-esr115? → approval-comm-esr115+

mail/components/addrbook/content/aboutAddressBookCommands.mjs does not exist on comm-esr115, this patch does not apply.

Flags: needinfo?(h.w.forms)
Attachment #9389213 - Flags: approval-comm-esr115+

[Approval Request Comment]
This should apply to esr115. Because of the different code structure, it is correct that only one line is added.

Flags: needinfo?(h.w.forms) → needinfo?(rob)
Attachment #9395882 - Flags: approval-comm-esr115?

Comment on attachment 9395882 [details] [diff] [review]
D203507.esr115.diff

[Triage Comment]
Approved for esr115

thanks for the revision

Attachment #9395882 - Flags: approval-comm-esr115? → approval-comm-esr115+
Flags: needinfo?(rob)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: