transparent gif is not displayed transparently in a form tag like "<input type='image' src='print..gif'>"

RESOLVED DUPLICATE of bug 184810

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 184810
15 years ago
15 years ago

People

(Reporter: Kristian Raue, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

If you use a transparent gif in a input tag of a form, the transparancy is 
replaced by a white background.


Sample:
<span style="background:#FF0033"><input type="image" src="print.gif"></span>

where print.gif is a transparent gif (see URL)


The sample does not contain a border attribut. If you add an border='0' 
attribut to the input tag, about half of the gif is transparent, the other 
half remains white. 

Reproducible: Always

Steps to Reproduce:
1. execute the URL in mozilla 1.2
2.
3.

Actual Results:  
gif has a white background

Expected Results:  
gif should have a red background
worksforme, linux trunk build.  Is this a problem with the WinXP "themed"
controls only?  Does the same problem happen on other Windows versions?

Comment 2

15 years ago
Also WFM using Mac OS X trunk build 2002120309

Comment 3

15 years ago
It appears you are right Boris, as it WFM with Win ME trunk 2002120308

*** This bug has been marked as a duplicate of 184810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.