positioned <object>'s backgrounds get painted over contents

RESOLVED DUPLICATE of bug 180502

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 180502
15 years ago
15 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: roc)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P2], URL)

(Reporter)

Description

15 years ago
See http://www.hixie.ch/tests/adhoc/html/object/003.html

An <object> element with position:absolute and a non-transparent background
renders its background on top of the contents of the <object>.

Also occurs for:
   position: relative http://www.hixie.ch/tests/adhoc/html/object/004.html
   -moz-opacity: 0.5  http://www.hixie.ch/tests/adhoc/html/object/005.html

Doesn't occur for:
   overflow: hidden   http://www.hixie.ch/tests/adhoc/html/object/006.html
   overflow: scroll   http://www.hixie.ch/tests/adhoc/html/object/007.html

Assigning to views since bz and dbaron seemed to think it was a views ordering
problem. Seems likely.
This made me think of bug 182874, although it's a somewhat random connection.
(Reporter)

Comment 2

15 years ago
This was originally spotted on http://www.tantek.com/log/2002/12.html, but that
page has since been changed to not explicitly set a background on the <object>
element in question.
Keywords: testcase
Whiteboard: [Hixie-P2]
(Reporter)

Updated

15 years ago
Summary: positoned <object>'s backgrounds get painted over contents → positioned <object>'s backgrounds get painted over contents
This bug is fixed by my patch in bug 180502.

*** This bug has been marked as a duplicate of 180502 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.