Closed Bug 1833873 Opened 10 months ago Closed 5 months ago

Use dialog initial focus for dialog popovers

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1836057

People

(Reporter: zsun, Assigned: zsun)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

The wpt test file (popover-dialog-initial-focus.html) has been merged to popver-focus.html
in upstream (https://github.com/web-platform-tests/wpt/commit/c5fd23342c88e3540eee13ffb42262c9dc085d1e).
However, with popover feature in Gecko still in development stage, we have a lot of failures
at popver-focus.html and the test result doesn't respsents (clearly) the effect of this chage.
Thus, we temporarily re-introduce the initial wpt test file that focuses on testing this change.
This test file will be removed once we fix other focus issues in the merged test file.

Assignee: nobody → zsun
Blocks: popover
Depends on: 1831057
Status: NEW → ASSIGNED
Blocks: 1827424
Attachment #9334820 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Duplicate of bug: 1836057
Resolution: --- → DUPLICATE
Duplicate of this bug: 1827424
You need to log in before you can comment on or make changes to this bug.