If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

search doesn't work after accidentally hitting enter in location bar

VERIFIED DUPLICATE of bug 135363

Status

SeaMonkey
Search
--
minor
VERIFIED DUPLICATE of bug 135363
15 years ago
9 years ago

People

(Reporter: Jonas Diemer, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

I enter a string to search for (at google) in the location bar. Normally, I hit
<down> to select "search Google for xyz" and then hit enter.

If you accidentally hit enter w/o selecting "Search Google for xyz" first, a
dialog opens saying "xyz could not be found. Please check the name and try
again.". This is logically, because mozilla interprets the entered string as an
address.

after closing that dialog, I give focus to the address bar again (which still
contains my serach string). then I hit <down> and select "Search Google for
xyz". Now the same dialog appears again.

If i add a char to my search string or if I delete the last character and type
it again, it works...



Reproducible: Always

Steps to Reproduce:
1.enter string to search for in addres-field
2.accidentally hit enter, close the dialog
3.hit <down> to select "Search Google for ..." (which you should have done
before, instead of accidentally hitting enter"


Actual Results:  
The dialog reappears

Expected Results:  
Search google for my string.

Note: Might be duplicate of 163436???

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 135363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
verified dup
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.