Closed Bug 18346 Opened 20 years ago Closed 20 years ago

Need to keep summary of summary files file from getting stale

Categories

(MailNews Core :: Backend, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

(Whiteboard: Fix in hand)

We need to keep the summary of summary files from getting stale, e.g., when we
crash before updating it. In 4.x, this was done by deleting the file after
opening it and recreating it anew each time we shut down. That would work for
5.0, but it would be much nicer to stick a time stamp in each folder, or
something so we could have a partially valid summary and not load all databases
at startup after every crash.
Status: NEW → ASSIGNED
Target Milestone: M14
accepting, m14
Wouldn't hold b1 for this. David, what do you think?
Target Milestone: M14 → M15
I guess not, but it's very confusing for users. I guess we'd better just not 
crash :-(
moving to m16
Target Milestone: M15 → M16
Mail Review recommends beta2 stopper.
Keywords: nsbeta2
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17
Putting on [nsbeta2-] radar. Not critical to beta2.  Spoke with phil.
Whiteboard: [nsbeta2-]
adding nsbeta3 keyword
Keywords: nsbeta3
Keywords: nsbeta2correctness
Whiteboard: [nsbeta2-]
Target Milestone: M17 → M18
*** Bug 46011 has been marked as a duplicate of this bug. ***
recommend nsbeta3+
Whiteboard: Fix in hand
fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
david, safe to mark this verified? I think summary files are working fine now 
and do get regenerated when I start mail after a crash.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.