crash when scrolling down some pages on www.theregister.co.uk

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: matthew.booth, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021128
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021128

If you navigate to http://www.theregister.co.uk/content/6/28422.html and scroll
(by any method, keyboard, scrollbar drag, etc) about half way down the page,
mozilla will crash. This happens on most pages on theregister.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://www.theregister.co.uk/content/6/28422.html
2. Scroll down the page
Actual Results:  
Mozilla crashes

Expected Results:  
Not crashed

I am using galeon 1.2.7 with mozilla 1.2.1 with xft support. I have also
reproduced this bug using mozilla alone (with xft support).
Please provide a stack trace
-> blizzard (should be a dupe)
Assignee: asa → blizzard
(Assignee)

Comment 3

15 years ago
Don't see it here, but I'm running a tip build.
Blocks: 172768

Updated

15 years ago
Keywords: crash
(Reporter)

Comment 4

15 years ago
I'm running the _rh8_xft rpms. What's the best way to get a stack trace?
(Assignee)

Comment 5

15 years ago
Attach gdb to the mozilla-bin process and wait for the crash.  Do you know how
to use gdb?
(Reporter)

Comment 6

15 years ago
Ok, I thought I did :) Obviously it's just been too long. I attached gdb to a
running process and when it crashed I just got:

Program exited with code 01.

I ran mozilla-bin with gdb which gave a bit more output. I got:

This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) run
Starting program: /usr/lib/mozilla-1.2.1/mozilla-bin 
[New Thread 8192 (LWP 16896)]
[New Thread 16385 (LWP 16899)]
[New Thread 8194 (LWP 16900)]
[New Thread 16387 (LWP 16901)]
[New Thread 24580 (LWP 16902)]
[New Thread 32773 (LWP 16903)]
Xlib:  extension "RENDER" missing on display ":0.0".
[New Thread 40966 (LWP 16908)]
[New Thread 49159 (LWP 16909)]
[New Thread 57352 (LWP 16910)]
[New Thread 65545 (LWP 16911)]
[New Thread 73738 (LWP 16912)]
[New Thread 81931 (LWP 16913)]
[New Thread 90124 (LWP 16914)]
[New Thread 98317 (LWP 16915)]
[New Thread 106510 (LWP 16916)]
Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 19172 error_code 2 request_code 53 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 19173 error_code 9 request_code 55 minor_code 0

Program exited with code 01.
(gdb) 

No core dump though. Anything I'm not doing?

Comment 7

15 years ago
do you have microsoft fonts .fon in your font directories ? See bug 180309.
Can you load the "render" extension via XFree86 (if available on your video
card) and does it help (not crashing) ?
no answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.