Inconsistant use of the close button on the tab bar

RESOLVED DUPLICATE of bug 156082

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 156082
16 years ago
10 years ago

People

(Reporter: Chris, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

If I have multiple tabs open and I press the "x" button the tab with focus will
close.  If there is only one tab open and I press the "x" button the tab bar
will close and the page displayed in the tab will still be displayed.

Reproducible: Always

Steps to Reproduce:
1.Load two tabs into your browser
2.Press the "x" button on the tab bar. The the tab with focus will close.
3.Press the "x" button on the tab bar. The tab bar will close leaving the page
you meant to close still loaded in the browser.

Actual Results:  
The tab bar closed instead of closing the tab with focus.

Expected Results:  
There are three good solutions to the inconsistant use of the close button on
the tab bar.
1. When there is only one tab open disable the close button.
2. When there is only one tab open, pressing the "x" button closes the tab
leaving the tab bar in place with no tabs displayed.
3. When there is only one tab open, pressing the "x" button replaces the
contents of the tab with a blank page.

Solution number two would provide the most consistant use of the close button on
the tab bar.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 156082 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.