Closed Bug 1834826 Opened 1 year ago Closed 1 year ago

Folder mode header context menu should not be the one of the very first item in the folder pane instead

Categories

(Thunderbird :: Folder and Message Lists, task)

Thunderbird 115

Tracking

(thunderbird_esr102 unaffected, thunderbird115 fixed)

RESOLVED FIXED
116 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird115 --- fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(1 file)

Currently, when right clicking on any folder mode header, focus moves to the very first item in the folder pane and shows the context menu of that item.

This fairly disorienting, especially since the actions don't actually map to where your mouse is. With the kebab menu on the folder mode headers coming to every mode for moving them around, we should consider if we want to just show the kebab menu as context menu on those headers instead. This would mean that right clicking will not change focus.

Summary: Folder mode header context menu → Folder mode header context menu should not be the one of the very first item in the folder pane instead
Whiteboard: [Supernova3p]

We should prevent the showing of the context menu if the event.target of the right click is on the folder mode header.

Assignee: nobody → martin
Target Milestone: --- → 116 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/dae2cc4bffb1
Don't show folder context menu on mode headers. r=aleca

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9337816 [details]
Bug 1834826 - Don't show folder context menu on mode headers. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Context menu with unrelated actions shown when right clicking folder pane mode header
Testing completed (on c-c, etc.): Manually tested on c-c.
Risk to taking this patch (and alternatives if risky): Affects the not-displaying logic of the folder pane context menu. Should be fairly low risk.

Attachment #9337816 - Flags: approval-comm-beta?

Comment on attachment 9337816 [details]
Bug 1834826 - Don't show folder context menu on mode headers. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9337816 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: