Closed Bug 1835229 Opened 1 year ago Closed 1 year ago

Opening result(in same page) from no-ads SERP(google) records an abandonment instead of a no-ads engagement

Categories

(Firefox :: Search, defect, P2)

Firefox 115
Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1835321
Tracking Status
firefox-esr102 --- unaffected
firefox113 --- unaffected
firefox114 --- unaffected
firefox115 --- affected

People

(Reporter: aflorinescu, Unassigned)

References

(Blocks 1 open bug)

Details

Found in

  • 115.0a1 (2023-05-25)

Affected versions

  • 115.0a1 (2023-05-25)

Tested platforms

  • Affected platforms:
    - Windows 10
    - Mac 13.2.1
    - Ubuntu 22.04

Preconditions

  • Have VPN connected to CA/US.
  • Google as default search engine.
  • browser.search.region set to CA/US
  • browser.search.serpEventTelemetry.enabled set to true.
  • browser.search.log set to true.

Steps to reproduce

  1. Open Firefox
  2. Open a new tab, focus address bar and submit michael jackson as a search query.
  3. From SERP, click on the wikipedia result.
  4. Check browser console/glean server.

Expected result
There should be the following 2 events logged for the above steps:

  • no-ads page impression:
    (Object { impressionId: "af84630f-9c2f-402d-9cea-1b324a305394", provider: "google", tagged: true, partnerCode: "firefox-b-d", source: "urlbar", isShoppingPage: false, hasShopping: false })
  • no-ads page engagement: (this is an example from from ctrl+click )
    Object { impressionId: "af84630f-9c2f-402d-9cea-1b324a305394", type: "non_ads_link", URL: "https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwjKs9SCupL_AhVC3qQKHbS-CjAQFnoECGIQAQ&url=https%3A%2F%2Fro.wikipedia.org%2Fwiki%2FMichael_Jackson&usg=AOvVaw2i5EovB92253Jd9X5bhsKb" }

Actual result
The following 2 events are logged for the above steps:

  • no-ads page SERP
    (Object { impressionId: "0667330e-e724-4fb2-87ad-ba2509acd250", provider: "google", tagged: true, partnerCode: "firefox-b-d", source: "urlbar", isShoppingPage: false, hasShopping: false })
  • abandonment
    Recording an abandonment event for impression id 0667330e-e724-4fb2-87ad-ba2509acd250 with reason: navigation

Regression range

  • N/A

Notes

  • Please note that initially we've thought that the same scenario applies to BING as well, if the default way to open the pages for BING SERP is custom modified to open in same tab/page (default is open in new tab/page), but apparently BING always adds the shopping tab to the SERP, so we can't get results that are in the no-ads category

:aflorinescu, if you think that's a regression, could you try to find a regression range using for example mozregression?

Depends on: 1835321
Priority: -- → P2

Hi Adrian, could we try verifying this bug still happens? I pushed some code a few weeks ago that should address this.

Flags: needinfo?(aflorinescu)

I've also taken a look at this again, and I'm not sure what the expected results should be given what code is currently in 115, but it's clearly not what I would expect for the given STR, or the original reported actual result:

SearchService: getVisibleEngines: getting all visible engines SearchService.sys.mjs:367:21 SearchTelemetry: Impression: google:tagged:firefox-b-1-d https://www.google.com/search?client=firefox-b-1-d&q=michael+jackson SearchSERPTelemetry.sys.mjs:763:21 SearchTelemetry: Ignoring activity from ambiguous responses 11 SearchSERPTelemetry.sys.mjs:935:25 The resource at “https://googleads.g.doubleclick.net/adsid/google/si?gadsid=AORoGNTM6GBW8tpklCYsnQbJF2FDIlaIX-CQNNAQ4twmjA9Tevncng3tNLva1Wvz9vvIhLHhpDrwCdQ4W5YZ” was blocked by OpaqueResponseBlocking. Reason: “nosniff is true and mimeType is an opaque-blocklisted MIME type or its essence is 'text/plain'”. SearchTelemetry: Ignoring activity from ambiguous responses 4 SearchSERPTelemetry.sys.mjs:935:25

For 116.0a1 (2023-06-12), same notes along the lines of 1835267#c7, the impression catches the shopping tab and also it doesn' record abandonment, but the STR expected non-ads engagement - so I'd say it's fixed for 116. Could you please mark it as such, with reference to what fixed it -(was it bug 1835321 ?). Also can you clarify if we're going to uplift it to 115b - for now, 115b report is due on 06/14 and is still affected.

Flags: needinfo?(aflorinescu) → needinfo?(jteow)

Thanks for checking Adrian,

Couple things, I'll discuss with Mark if we can find a way to make the logging less noisy. Seeing "SearchTelemetry: Ignoring activity from ambiguous responses" is not particularly helpful for you or your team as it's not indicative of an error.

To be clear, what I'd expect while searching michael jackson is getting a search impression.

SearchTelemetry: "Reported Impression:" ({impressionId:"00cf900d-8d2d-498b-b9e4-5d9ee5e85822", provider:"google", tagged:true, partnerCode:"firefox-b-d", source:"urlbar", isShoppingPage:false, shoppingTabDisplayed:true})

It may or may not have an ad_impression, depending on whether or not ads are visible and if a shopping tab is visible. Shopping tabs especially while using a VPN in the US almost always show up for me.

Then upon clicking a Wikipedia link (for me it's on the right hand side), an engagement event on a non ads link:

SearchTelemetry: "Counting click:" ({impressionId:"00cf900d-8d2d-498b-b9e4-5d9ee5e85822", type:"non_ads_link", URL:"https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwjVt83-wMD_AhWfLUQIHXtoA6cQmhN6BAghEAI&url=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FMichael_Jackson&usg=AOvVaw2YU9kJ1BzVqODNXR22pom2"})

It seems like you pretty much got this result.

The fix landed a few weeks ago, so there shouldn't be any need for uplifts.

Status: NEW → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1835321
Flags: needinfo?(jteow)
Resolution: --- → DUPLICATE

Comment removed: see #c6

Flags: needinfo?(jteow)

Later edit: Removed the above comment since I've realized what the problem was: - I switched the nightly-beta with the same profile, hence literally being enrolled then unenrolled in the "serp-ad-telemetry-validation-rollout" which lead to disabling the browser.search.serpEventTelemetry.enabled due to version missmatch (while on b115).

Once I renabled the browser.search.serpEventTelemetry.enabled, everything worked fine on beta 115.0b5 as well.

Flags: needinfo?(jteow)
You need to log in before you can comment on or make changes to this bug.