Phoenix crashes trying to display the demo page.

VERIFIED WORKSFORME

Status

()

Firefox
General
--
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Bertilo Wennergren, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021204 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021204 Phoenix/0.4

The demo page is a cut down version of a page that originally gave this crash.
What's left that could be related to the problem is the following:

* A CSS setting of "p { max-width: 45em; }"

* Use of the UTF-8 encoding.

Actually the number of characters in the single text paragraph seems to be
critical as well. If I take out the _first two characters_, the crash does not
occur. Also removing other characters, or the "em" tags, or the asterisks, can help.

If I remove the "meta" element for UTF-8, Phoenix does not crash, but the page
initally takes surprisingly long to render.

This bug seems to depend on a lot of small details, and it probably appears only
once in a very blue moon.


Reproducible: Always

Steps to Reproduce:




Mozilla does not crash on this page.

Possibly this is related to bug 175558, who knows...

Since this seems to be related to the text width ("max-with: 45em") it wouldn't
surprise me if this bug only occurs with certain font size settings, certain
font families, etc.

Updated

16 years ago
Severity: normal → critical

Comment 1

16 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021129
Phoenix/0.4

Comment 2

16 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021204
Phoenix/0.4

Bertilo, did you do a clean install of Phoenix, as suggested in the release
notes? Do you use any extensions?
(Reporter)

Comment 3

16 years ago
No, I did not do a fresh install, and I do use a couple of extensions.

So, I just did a complete reinstall (same Phoenix version), without any
extensions, and virgin profile. At first the test page gave no trouble. Then I
set the font to "monotype-arial" (the sans-serif setting), like I usually do,
and the font size to 16px (those were the only settings I touched). And Phoenix
immediately crashed at the test page. I tested with "monotype-times new roman"
too - no problem.

The font "monotype-arial" normally gives no problems. I have about 700 pages
similar to the original problem page (the same general content, the same
CSS...), and Phoenix have no problems with them. It's just this one page, from
which I've isolated the troublesome paragraph and CSS in the test page.

Comment 4

16 years ago
Works fine on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021206
Phoenix/0.4.

I had some problems with CSS too... bug 182926

Comment 5

16 years ago
Just tried to dupe the problem using Gecko/20021214 Phoenix/0.5 but had no luck.

Reporter: Can you please describe step by step what you did to make Phoenix
crash? The problem is, that I don't have any "monotype-arial" entry contained in
any of the four comboboxes in screen Tools -> Preferences -> Fonts and colors.
So I played around with several other fonts and font soizes but Phoenix didn't
crashed on your demo page...
(Reporter)

Comment 6

16 years ago
The steps are:

(0. Use Linux.)
1. Use a virgin install of Phoenix.
2. Set font to "monotype-arial".
3. Set font size to 16px.
4. Load test page.
5. Watch Phoenix crash.

As I've already written, this bug seems to show itself only under very peculiar
and specific circumstances. E.g. deleting one or two characters in the test page
will result in Phoenix having no problems. Perhaps you'll need to use my exact
window size and resolution...

Perhaps the crashes I've seen on the following page are related, although there
is no need for "monotype-arial":

<URL:http://www.akademio-de-esperanto.org/fundamento/ekzercaro.php>

For that page you need to pump up the font size a bit with text-zoom, and
Phoenix will crash (Mozilla survives).

Comment 7

16 years ago
Sorry - even with the second page you reported I'm not able to crash Phoenix on
my system - I loaded the page completely and then increased the font size even
to the maximum possible value, but the only thing I noticed was, that Phoenix
needs a while to complete this task when reaching larger font sizes...
(Reporter)

Comment 8

16 years ago
It could be the second page bug needs a TrueType font to eat. I think I used
"Times New Roman" (monotype) when I got the second crash. The original bug only
eats "monotype-arial" though. I've used "monotype-arial" for all browsing for a
long time, and only the one test page (and the original version of it) has ever
given me any grief.

Bugs are a weird species...

Comment 9

16 years ago
Bertilo, can you reproduce this in Mozilla (getting a talkback report from a
Mozilla crash would help a lot) or reproduce in a debug build so we can get a
stack trace?
(Reporter)

Comment 10

16 years ago
Sorry, Ada, but this bug has never ever showed itself in Mozilla, only in
Phoenix. I still get it from time to time. Then I just restart Phoenix, and
switch to a different font before loading the page again.

Are there debug builds of Phoenix?

Comment 11

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030202 
Phoenix/0.5

This page gives no problem
I can't reproduce this on Windows on the second test page using today's build.
When trying to get to the first test page I only get a 404.
(Reporter)

Comment 13

16 years ago
Sorry guys, the testpage at http://www.bertilow.com/div/crash-phoenix/ died when
I reinstalled my system and did a clean up of my web pages. No back-up! :( I
don't think it matters though, since no one has been able to reproduce the
error. I'm using Mozilla right now (not Phoenix) and I don't get these crashes
anymore.

You can kill this bug if you want to. If the beast turns up again, I'll report a
new bug.

Comment 14

16 years ago
Well - so I mark this one as "Works for me"... If anyone has any objections on
this feel free to change the state of the bug - I don't want to mark it as
"Invalid" as obviously a problem existed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.