Chimera doesn't always use Launch Services (ex. FTP)

VERIFIED WONTFIX

Status

Camino Graveyard
OS Integration
--
minor
VERIFIED WONTFIX
16 years ago
16 years ago

People

(Reporter: Cortland Klein, Assigned: Steve Dagley)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021204 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021204 Chimera/0.6+

I have told Launch Services to handle FTP in a particular FTP client. Just
because Chimera already has an FTP protocol handler doesn't mean that it should
ignore Launch Services. It should instead register itself with LS and then have
a preference pane to tell it what protocols it should handle or pass out to LS.
(For example, a list of checkboxes with HTTP, HTTPS, FTP, etc...)

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
->dagley
Assignee: sfraser → sdagley
(Assignee)

Comment 2

16 years ago
This is by design.  If Chimera knows how to handle a protocol it's gonna handle
it internally.  If the user wishes to override that they can add a per-protocol
pref to their user.js file such as:

    user_pref("network.protocol-handler.external.mailto", true);

Not that mailto is a protocol Chimera will attempt to handle itself but it
illustrates the usage.  And no, we have no plans to add UI for setting this as
it isn't something most users would ever need to see.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 3

16 years ago
*** Bug 185835 has been marked as a duplicate of this bug. ***
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.