Non-English characters displayed as question marks in window title bar

VERIFIED INVALID

Status

()

Core
Internationalization
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: David Greenaway, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

On opening the page http://www.gday.ru/, the windows title bar and the window
title in the Windows start bar do not correctly show the title of the web page,
but instead replaces non-english characters as question marks.

Manually viewing source and looking at the text between the two <title> shows
the correct page title.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.gday.ru/
2. Look at Windows Title Bar

Actual Results:  
The window title showed "G'Day.ru / ??????? ? ?? ???????? ???"

Expected Results:  
The window title should show "G'Day.ru / [russion text]"

Comment 1

15 years ago
Works for me on 12-04 unicode trunk build / WinXP.

I believe it's a dup of bug 9449, it has been fixed in latest unicode build,
please install a new build to see you still see it.
Keywords: intl

Comment 2

15 years ago
Don't use the unicode build available from ftp.mozilla.org.
Just use the latest trunk build.  It's unicode enabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
Mark as verified per comment above also it's WORKSFORME.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.