http headers displayed on redirect in frameset

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
16 years ago
12 years ago

People

(Reporter: brett, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021127
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021127

visiting the above URL, the centre frame is a redirect. In Mozilla, the HTTP
headers are displayed and the 302 does not occur.

If I then click that frame and say "show only this frame", the redirect occurs
properly

Reproducible: Always

Steps to Reproduce:
visit the url
Actual Results:  
got the headers of the redirect

Expected Results:  
have the redirect occur

also broken in Mozilla 1.0.1
(Reporter)

Comment 1

16 years ago
I have determined what this is.

The frame src has a newline between the URL and the closing quote. Removing it
fixes the problem.

Obviously this is wrong - so I've fixed it and removed the URL as it no longer
displays it.

However, should Mozilla handle it differently?

Comment 2

16 years ago
adding back the URL

Comment 3

16 years ago
sorry - i thought someone else removed the url. re-removing

Comment 4

16 years ago
A simple HTML file (see below) works as expected without errors with my 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312  (Same build
without erros on Win2k)

<html><head><title></title></head>
<frameset rows="80,*" frameborder="NO" border="0" framespacing="0"> 
  <frame name="topFrame" scrolling="NO" noresize src="http://www.mozilla.org
" >
  <frame name="mainFrame" src="http://www.mozilla.org
">
</frameset><noframes><body></body></noframes></html>

Comment 5

15 years ago
not a bug, see comment 1.
-> INVALID
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.