Closed Bug 183738 Opened 22 years ago Closed 22 years ago

Mozilla 1.2.1 fails to compile with Qt toolkit

Categories

(SeaMonkey :: Build Config, defect)

Other
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 178987

People

(Reporter: absinthe, Assigned: netscape)

Details

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3; Linux 2.4.19-gentoo-r9)
Build Identifier: 

Cannot compile Mozilla 1.2.1 with the Qt toolkit (as default or otherwise) on       
Linux 2.4.19... this is the only toolkit I want Mozilla to build with (Qt).       
      
gcc version 3.2     
glibc version 2.3.1   
GNU Make 3.80  
qt version 3.1.0  
      
       

Reproducible: Always

Steps to Reproduce:
1. --enable-toolkit=qt --enable-default-toolkit=qt --disable-toolkit-gtk  
--disable-toolkit-xlib --with-qtdir=/usr/qt/3/lib --disable-xft --enable-svg  
--with-x --with-pthreads --with-system-jpeg --with-system-png   
--with-system-zlib --with-system-mng   
 
2. make        
     
Actual Results:  
make[4]: Entering directory `/tmp/mozilla-1.2.1/work/mozilla/gfx/src/qt' 
make[4]: warning: -jN forced in submake: disabling jobserver mode. 
nsDeviceContextQT.cpp 
g++ -o nsDeviceContextQT.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" -DOJI 
-D_BSD_SOURCE -I./. -I./..  -I../../../dist/include/xpcom 
-I../../../dist/include/string -I../../../dist/include/widget 
-I../../../dist/include/view -I../../../dist/include/uconv 
-I../../../dist/include/pref -I../../../dist/include/util 
-I../../../dist/include/js -I../../../dist/include/mozcomps 
-I../../../dist/include/unicharutil -I../../../dist/include/intl 
-I../../../dist/include/locale -I../../../dist/include/gfx 
-I../../../dist/include -I/tmp/mozilla-1.2.1/work/mozilla/dist/include/nspr      
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -frtti -fno-exceptions  
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth 
-Wno-ctor-dtor-privacy -Wno-long-long -O3 -march=athlon-tbird -pipe 
-Wno-deprecated -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED 
-ffunction-sections  -I/usr/qt/3/include -DQT_GENUINE_STR  
-I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h 
-Wp,-MD,.deps/nsDeviceContextQT.pp nsDeviceContextQT.cpp 
nsDeviceContextSpecFactoryQT.cpp 
g++ -o nsDeviceContextSpecFactoryQT.o -c -DOSTYPE=\"Linux2.4\" 
-DOSARCH=\"Linux\" -DOJI -D_BSD_SOURCE -I./. -I./..  
-I../../../dist/include/xpcom -I../../../dist/include/string 
-I../../../dist/include/widget -I../../../dist/include/view 
-I../../../dist/include/uconv -I../../../dist/include/pref 
-I../../../dist/include/util -I../../../dist/include/js 
-I../../../dist/include/mozcomps -I../../../dist/include/unicharutil 
-I../../../dist/include/intl -I../../../dist/include/locale 
-I../../../dist/include/gfx -I../../../dist/include 
-I/tmp/mozilla-1.2.1/work/mozilla/dist/include/nspr      -I/usr/X11R6/include   
-fPIC  -I/usr/X11R6/include -frtti -fno-exceptions  -Wconversion 
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth 
-Wno-ctor-dtor-privacy -Wno-long-long -O3 -march=athlon-tbird -pipe 
-Wno-deprecated -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED 
-ffunction-sections  -I/usr/qt/3/include -DQT_GENUINE_STR  
-I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h 
-Wp,-MD,.deps/nsDeviceContextSpecFactoryQT.pp nsDeviceContextSpecFactoryQT.cpp 
In file included from nsDeviceContextSpecFactoryQT.cpp:41: 
../../../dist/include/gfx/nsIDeviceContextSpecPS.h:128: warning: `virtual 
nsresult nsIDeviceContextSpecPS::GetPrinterName(const char**)' was hidden 
nsDeviceContextSpecQT.h:79: warning:   by `virtual nsresult 
nsDeviceContextSpecQT::GetPrinterName(char**)' 
../../../dist/include/gfx/nsIDeviceContextSpecPS.h:120: warning: `virtual 
nsresult nsIDeviceContextSpecPS::GetCommand(const char**)' was hidden 
nsDeviceContextSpecQT.h:95: warning:   by `virtual nsresult 
nsDeviceContextSpecQT::GetCommand(char**)' 
../../../dist/include/gfx/nsIDeviceContextSpecPS.h:144: warning: `virtual 
nsresult nsIDeviceContextSpecPS::GetPath(const char**)' was hidden 
nsDeviceContextSpecQT.h:97: warning:   by `virtual nsresult 
nsDeviceContextSpecQT::GetPath(char**)' 
In file included from nsDeviceContextQT.cpp:46: 
../../../dist/include/gfx/nsDeviceContext.h:97: warning: `virtual nsresult 
DeviceContextImpl::CreateRenderingContext(void*, nsIRenderingContext*&)' was 
hidden 
nsDeviceContextQT.h:64: warning:   by `virtual nsresult 
nsDeviceContextQT::CreateRenderingContext(nsIWidget*, nsIRenderingContext*&)' 
In file included from nsDeviceContextSpecFactoryQT.cpp:42: 
../../../dist/include/gfx/nsIRenderingContext.h:655: warning: `virtual 
nsresult nsIRenderingContext::GetTextDimensions(const PRUnichar*, int, int, 
PRInt32*, int, nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32*)' was 
hidden 
nsRenderingContextQT.h:163: warning:   by `virtual nsresult 
nsRenderingContextQT::GetTextDimensions(const PRUnichar*, unsigned int, 
nsTextDimensions&, PRInt32*)' 
../../../dist/include/gfx/nsIRenderingContext.h:645: warning: `virtual 
nsresult nsIRenderingContext::GetTextDimensions(const char*, int, int, 
PRInt32*, int, nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32*)' was 
hidden 
nsRenderingContextQT.h:163: warning:   by `virtual nsresult 
nsRenderingContextQT::GetTextDimensions(const PRUnichar*, unsigned int, 
nsTextDimensions&, PRInt32*)' 
../../../dist/include/gfx/nsRenderingContextImpl.h:138: warning: `virtual 
nsresult nsRenderingContextImpl::DrawImage(imgIContainer*, const nsRect*, 
const nsPoint*)' was hidden 
nsRenderingContextQT.h:190: warning:   by `virtual nsresult 
nsRenderingContextQT::DrawImage(nsIImage*, const nsRect&, const nsRect&)' 
../../../dist/include/gfx/nsRenderingContextImpl.h:140: warning: `virtual 
nsresult nsRenderingContextImpl::DrawTile(imgIContainer*, int, int, const 
nsRect*)' was hidden 
nsRenderingContextQT.h:195: warning:   by `virtual nsresult 
nsRenderingContextQT::DrawTile(nsIImage*, int, int, const nsRect&)' 
In file included from nsDeviceContextQT.cpp:50: 
../../../dist/include/gfx/nsIRenderingContext.h:655: warning: `virtual 
nsresult nsIRenderingContext::GetTextDimensions(const PRUnichar*, int, int, 
PRInt32*, int, nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32*)' was 
hidden 
nsRenderingContextQT.h:163: warning:   by `virtual nsresult 
nsRenderingContextQT::GetTextDimensions(const PRUnichar*, unsigned int, 
nsTextDimensions&, PRInt32*)' 
../../../dist/include/gfx/nsIRenderingContext.h:645: warning: `virtual 
nsresult nsIRenderingContext::GetTextDimensions(const char*, int, int, 
PRInt32*, int, nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32*)' was 
hidden 
nsRenderingContextQT.h:163: warning:   by `virtual nsresult 
nsRenderingContextQT::GetTextDimensions(const PRUnichar*, unsigned int, 
nsTextDimensions&, PRInt32*)' 
../../../dist/include/gfx/nsRenderingContextImpl.h:138: warning: `virtual 
nsresult nsRenderingContextImpl::DrawImage(imgIContainer*, const nsRect*, 
const nsPoint*)' was hidden 
nsRenderingContextQT.h:190: warning:   by `virtual nsresult 
nsRenderingContextQT::DrawImage(nsIImage*, const nsRect&, const nsRect&)' 
../../../dist/include/gfx/nsRenderingContextImpl.h:140: warning: `virtual 
nsresult nsRenderingContextImpl::DrawTile(imgIContainer*, int, int, const 
nsRect*)' was hidden 
nsRenderingContextQT.h:195: warning:   by `virtual nsresult 
nsRenderingContextQT::DrawTile(nsIImage*, int, int, const nsRect&)' 
nsDeviceContextSpecQT.cpp 
g++ -o nsDeviceContextSpecQT.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" 
-DOJI -D_BSD_SOURCE -I./. -I./..  -I../../../dist/include/xpcom 
-I../../../dist/include/string -I../../../dist/include/widget 
-I../../../dist/include/view -I../../../dist/include/uconv 
-I../../../dist/include/pref -I../../../dist/include/util 
-I../../../dist/include/js -I../../../dist/include/mozcomps 
-I../../../dist/include/unicharutil -I../../../dist/include/intl 
-I../../../dist/include/locale -I../../../dist/include/gfx 
-I../../../dist/include -I/tmp/mozilla-1.2.1/work/mozilla/dist/include/nspr      
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -frtti -fno-exceptions  
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth 
-Wno-ctor-dtor-privacy -Wno-long-long -O3 -march=athlon-tbird -pipe 
-Wno-deprecated -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED 
-ffunction-sections  -I/usr/qt/3/include -DQT_GENUINE_STR  
-I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h 
-Wp,-MD,.deps/nsDeviceContextSpecQT.pp nsDeviceContextSpecQT.cpp 
In file included from nsDeviceContextSpecQT.cpp:40: 
../../../dist/include/gfx/nsIDeviceContextSpecPS.h:128: warning: `virtual 
nsresult nsIDeviceContextSpecPS::GetPrinterName(const char**)' was hidden 
nsDeviceContextSpecQT.h:79: warning:   by `virtual nsresult 
nsDeviceContextSpecQT::GetPrinterName(char**)' 
../../../dist/include/gfx/nsIDeviceContextSpecPS.h:120: warning: `virtual 
nsresult nsIDeviceContextSpecPS::GetCommand(const char**)' was hidden 
nsDeviceContextSpecQT.h:95: warning:   by `virtual nsresult 
nsDeviceContextSpecQT::GetCommand(char**)' 
../../../dist/include/gfx/nsIDeviceContextSpecPS.h:144: warning: `virtual 
nsresult nsIDeviceContextSpecPS::GetPath(const char**)' was hidden 
nsDeviceContextSpecQT.h:97: warning:   by `virtual nsresult 
nsDeviceContextSpecQT::GetPath(char**)' 
nsDeviceContextQT.cpp: In member function `virtual nsresult 
nsDeviceContextQT::CreateRenderingContext(nsIRenderingContext*&)': 
nsDeviceContextQT.cpp:215: cannot allocate an object of type 
`nsRenderingContextQT' 
nsDeviceContextQT.cpp:215:   because the following virtual functions are 
abstract: 
../../../dist/include/gfx/nsIRenderingContext.h:645:    virtual nsresult 
nsIRenderingContext::GetTextDimensions(const char*, int, int, PRInt32*, int, 
nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32* = 0) 
../../../dist/include/gfx/nsIRenderingContext.h:655:    virtual nsresult 
nsIRenderingContext::GetTextDimensions(const PRUnichar*, int, int, PRInt32*, 
int, nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32* = 0) 
make[4]: *** [nsDeviceContextQT.o] Error 1 
make[4]: *** Waiting for unfinished jobs.... 
In file included from nsDeviceContextSpecQT.cpp:41: 
../../../dist/include/gfx/nsIRenderingContext.h:655: warning: `virtual 
nsresult nsIRenderingContext::GetTextDimensions(const PRUnichar*, int, int, 
PRInt32*, int, nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32*)' was 
hidden 
nsRenderingContextQT.h:163: warning:   by `virtual nsresult 
nsRenderingContextQT::GetTextDimensions(const PRUnichar*, unsigned int, 
nsTextDimensions&, PRInt32*)' 
../../../dist/include/gfx/nsIRenderingContext.h:645: warning: `virtual 
nsresult nsIRenderingContext::GetTextDimensions(const char*, int, int, 
PRInt32*, int, nsTextDimensions&, PRInt32&, nsTextDimensions&, PRInt32*)' was 
hidden 
nsRenderingContextQT.h:163: warning:   by `virtual nsresult 
nsRenderingContextQT::GetTextDimensions(const PRUnichar*, unsigned int, 
nsTextDimensions&, PRInt32*)' 
../../../dist/include/gfx/nsRenderingContextImpl.h:138: warning: `virtual 
nsresult nsRenderingContextImpl::DrawImage(imgIContainer*, const nsRect*, 
const nsPoint*)' was hidden 
nsRenderingContextQT.h:190: warning:   by `virtual nsresult 
nsRenderingContextQT::DrawImage(nsIImage*, const nsRect&, const nsRect&)' 
../../../dist/include/gfx/nsRenderingContextImpl.h:140: warning: `virtual 
nsresult nsRenderingContextImpl::DrawTile(imgIContainer*, int, int, const 
nsRect*)' was hidden 
nsRenderingContextQT.h:195: warning:   by `virtual nsresult 
nsRenderingContextQT::DrawTile(nsIImage*, int, int, const nsRect&)' 
nsDeviceContextSpecQT.cpp: In member function `virtual nsresult 
nsDeviceContextSpecQT::Init(nsIPrintSettings*)': 
nsDeviceContextSpecQT.cpp:134: `do_GetService' undeclared (first use this 
function) 
nsDeviceContextSpecQT.cpp:134: (Each undeclared identifier is reported only 
once for each function it appears in.) 
nsDeviceContextSpecQT.cpp:178: `ToNewCString' undeclared (first use this 
function) 
nsDeviceContextSpecQT.cpp:194: `kCommandStr' undeclared (first use this 
function) 
make[4]: *** [nsDeviceContextSpecQT.o] Error 1 
make[4]: Leaving directory `/tmp/mozilla-1.2.1/work/mozilla/gfx/src/qt' 
make[3]: *** [libs] Error 2 
make[3]: Leaving directory `/tmp/mozilla-1.2.1/work/mozilla/gfx/src' 
make[2]: *** [libs] Error 2 
make[2]: Leaving directory `/tmp/mozilla-1.2.1/work/mozilla/gfx' 
make[1]: *** [tier_9] Error 2 
make[1]: Leaving directory `/tmp/mozilla-1.2.1/work/mozilla' 
make: *** [default] Error 2
That is well known. There are talks about removing the Qt support frmo the tree.
Resolving as dup of that bug.

*** This bug has been marked as a duplicate of 178987 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Severity: blocker → normal
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.