Closed Bug 1837438 Opened 1 year ago Closed 1 year ago

Mail accounts with insecure connection have no icon in get messages context menu

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird115? fixed)

RESOLVED FIXED
116 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird115 ? fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(2 files)

Attached image screenshot.png

STR:

  • Set up a mail account without secure connection (or cheat and remove the secure flag from the menuitem)
  • Right click on the get messages button in the folder pane header

Expected result:
The envelope icon without lock is shown

Actual result:
No icon is shown

Version: unspecified → Thunderbird 115
Whiteboard: [Supernova3p]
Target Milestone: --- → 116 Branch

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/7cf927ac046c
Add missing icon for non-secure mail accounts in get messages menu. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Depends on: 1817915

Comment on attachment 9338108 [details]
Bug 1837438 - Add missing icon for non-secure mail accounts in get messages menu. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): bug 1817915 introduced this menu, forgetting the icon for the insecure mail accounts
User impact if declined: Insecure mail accounts have no icon, while all other account types have an icon in the get messages details menu.
Testing completed (on c-c, etc.): Manual testing
Risk to taking this patch (and alternatives if risky): Low (style change only)

Attachment #9338108 - Flags: approval-comm-beta?

Comment on attachment 9338108 [details]
Bug 1837438 - Add missing icon for non-secure mail accounts in get messages menu. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9338108 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: