The default bug view has changed. See this FAQ.

can't click on positioned <object>s

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Bernd, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
win98 2002120508 
- The navigation bar on the right side is not clickable the links dont work
- The navigation bar is does not have a complete border.
one issue per bug please :-)

Comment 2

15 years ago
Created attachment 108447 [details]
testcase part 1

Comment 3

15 years ago
Created attachment 108448 [details]
testcase part 2 (load this one)

I see the border with linux, so here's a testcase for the unclickable links...
tested with linux trunk build 20021204

Updated

15 years ago
Keywords: testcase
OS: Windows 98 → All
(Reporter)

Comment 4

15 years ago
I think this may be caused by the fact that the nsObjectFrame does not have a
own GetFrameForPoint but uses the one from nsHTMLContainerFrame
Summary: navigation bar at tanteks log does not work → can't click on positioned <object>s

Updated

14 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 5

14 years ago
*** Bug 194469 has been marked as a duplicate of this bug. ***
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1528&action=view

Show this test cases.
when object element has "position:abslute;" or "position:relative;",
I can reproduce this problem with 2003022709-trunk/WinXP.
However, object element having fixed and static value is good.
hmm.. I tried implementing GetFrameForPoint on nsObjectFrame and that does not
seem to help (nor does passing the right parent frame to CreateViewForFrame, btw...

This could just be an issue with the fact that we give the child frame of the
<object> the same style context....

Comment 8

14 years ago
-> All (Mac problem too)
Hardware: PC → All
(Reporter)

Comment 9

13 years ago
wfm winxp 2003122009

Comment 10

13 years ago
This bug worksforme with Windows Seamonkey builds 2004020909
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.