Crash when selecting a date in the calendar on the page

RESOLVED DUPLICATE of bug 174579

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 174579
15 years ago
13 years ago

People

(Reporter: Alexander Skwar, Assigned: asa)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021130

Mozilla crashs when selecting a date from the calendar.  Sometimes, Mozilla
crashs right away, sometimes you've got to go to some other page and then go
back to make Mozilla crash.

Reproducible: Always

Steps to Reproduce:
The following makes Mozilla crash all the time:

1. Go to http://www.mitfahrzentrale.de
2. Select a date with the calendar icon.  Do *NOT* choose the current date, but
a date in the future.  I've chosen 13.12.02
3. Go to some other page, like http://www.heise.de
4. Follow some link.  I've clicked on "heise mobil"
5. Go back to mitfahrzentrale.  I've typed "www.mitfa" in the adress field and
selected http://www.mitfahrzentrale.de
6. Select some other date.  I've taken 24.12.

Actual Results:  
Boom

Expected Results:  
No Boom

This happens with Build 2002113005 on Linux and 2002120508 on Windows XP for me.
 Other users in the german newsgroup de.comm.software.mozilla also reported that
Mozilla crashs.  See the thread "[Crash] Moz 1.3a", for example at

http://groups.google.com/groups?dq=&hl=de&lr=&ie=UTF-8&threadm=asnepv%24t13p4%241%40ID-110599.news.dfncis.de&prev=/groups%3Fgroup%3Dde.comm.software.mozilla%26hl%3Dde
Please provide a talkback ID from that crash 

Comment 2

15 years ago
WFM with Build 2002113005 on Windows 2000

This site shows some banners that make use of javascript and flash. Most users
from dcsm reported that they have to reload the site some times to reproduce the
bug. So I think one of the advertisings is making some trouble.

I cannot reproduce it even after some reloads. Perhaps a problem with one plugin
(flash)?
flash - could be 

Reporter: Do you use flash5 ?
(Reporter)

Comment 4

15 years ago
I use Flash 6 on both platforms.

r60 on Linux and r47 on Windows
(Reporter)

Comment 5

15 years ago
After removing the Flash plugin, site doesn't crash anymore.

How can I get a talkback ID?
(Reporter)

Comment 6

15 years ago
Talkback ID: TB14761302E

Comment 7

15 years ago
Talkback ID: TB14743047M
Flash Plugin: Shockwave Flash 6.0 r47

I can reproduce it with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021202
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021205
(Reporter)

Comment 8

15 years ago
Updated to Builds of 20021207 for win32 and Linux.  Now the "click"path I
described doesn't crash Mozilla anymore.  Even with Flash plugin installed.

Changing to Resolved, WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

15 years ago
Reopening bug.  Crashed on Windows again.  Sorry :(  However, it doesn't crash
as easily anymore.

See Talkback ID TB14842062K

I'm using Orbit Retro theme.  Installed plugins:

- Java Plug-In 1.4.1_01
- Adobe Acrobat Plug-In v5.10
- QuickTime Plug-In 6.0.2
- Microsoft DRM
- Windows Media Player Plug-In DLL
- Microsoft Windows Media Services
- Flash 6.0r47
- Macromedia Shockwave for Director Netscape Plug-in, v8.5

See http://message-center.info/stuff/Plugins.html for the (badly formatted...)
about:plugins page of my Windows Mozilla.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Keywords: crash, stackwanted
Whiteboard: TB14842062K [M_V]

Comment 10

15 years ago
unfortunately those talkbacks are now out of date.

Alexander - can you reproduce this bug with a recent build? and post another
talkback ID? thanks.
Whiteboard: TB14842062K [M_V] → [M_V]
(Reporter)

Comment 11

15 years ago
It still crashes, after clicking quite some times on the calendar and moving to
different sites and back again.

Flash r65 is installed now and Mozilla 20030106 on XP.

Talkback ID: TB15864807G

Updated

15 years ago
Whiteboard: [M_V] → TB15864807G [M_V]
OnLinkClickEvent::OnLinkClickEvent
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp, line 508]
nsWebShell::OnLinkClick
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp, line 546]
nsGenericElement::TriggerLink
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 3024]
nsGenericHTMLElement::HandleDOMEventForAnchors
[c:/builds/seamonkey/mozilla/content/html/content/src/nsGenericHTMLElement.cpp,
line 1493]
nsHTMLLinkElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLLinkElement.cpp,
line 364]
nsGenericDOMDataNode::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericDOMDataNode.cpp, line 837]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6071]
PresShell::HandleEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6039]
nsEventStateManager::CheckForAndDispatchClick
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 2871]
nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 1843]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6108]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 5994]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2209]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 304]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1949]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1120]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1137]
nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5378]
ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5633]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 4134]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1404]
USER32.dll + 0x27ad7 (0x77d37ad7)
USER32.dll + 0x2ccd4 (0x77d3ccd4)
USER32.dll + 0x4455 (0x77d14455)
USER32.dll + 0x95d5 (0x77d195d5)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1559]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1907]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1927]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e614c7) 
Keywords: stackwanted
Whiteboard: TB15864807G [M_V]

*** This bug has been marked as a duplicate of 174579 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.