Advanced -> Quick Launch preference 'sticks' when changing profiles

VERIFIED INVALID

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
--
minor
VERIFIED INVALID
15 years ago
5 years ago

People

(Reporter: Mario Lia, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

If you have multiple profiles, and you change Advanced -> Quick Launch checkbox
in the preferences, this setting will take effect throughout all profiles. If
this is deemed a "feature" and not a bug, then this behavior should be noted
underneath the Quick Launch checkbox.

Reproducible: Always

Steps to Reproduce:
1. Create multiple profiles
2. Use one profile, and check the Quick Launch checkbox
3. Close mozilla completely, and then go into the another profile
4. un-check the Quick Launch checkbox
5. Close mozilla completely, and then go into the original profile
6. You will see that the checkbox is now un-checked


Expected Results:  
I thought the setting of this checkbox would be on a per profile basis, instead
of a global basis.
the panels itself doesn't belong to preferences.

AFAIK: You can't set if per profile basis since Mozila must place the
quicklaunch link in the autostart for that user.
It should work if you switch the logged in User , it doesn't make sense otherwise.
Assignee: ben → law
Component: Preferences → QuickLaunch (AKA turbo mode)
QA Contact: sairuh → gbush

Comment 2

15 years ago
agreed, setting the preference sets a registry key which will be in use for all
profiles
working as designed

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 4

15 years ago
verified
Status: RESOLVED → VERIFIED
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.