Accessing certain SSL pages cause Mozilla to hang

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
16 years ago
2 years ago

People

(Reporter: zach, Assigned: ssaux)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Accessing the above SSL server loads slowly.  Images rarely load, if at all. 
Clicking on links produces no visible results.  This only works on certain HTTPS
servers (I believe these are Netscape Enterprise) this is the only instance I
can find.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. type in URL
3. Become disappointed

Actual Results:  
Page fails to load

Expected Results:  
Page should load

Comment 1

16 years ago
reassigning to junruh.  I have tried and accessed the page without problem from
my linux and windows systems here at work using the 20021204 trunk builds.
Component: S/MIME → Client Library
QA Contact: carosendahl → junruh

Comment 2

16 years ago
Works for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1)
Gecko/20021130 Netscape/7.0+. 
Reporter, can you try setting up a new profile and see if there is any
improvement?  "./mozilla -ProfileManager".
The server is indeed a Netscape-Enterprise/3.6 SP3 - a fast and reliable server.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
I created a new profile, but no change.  Perhaps a bit more information is in order:

- The HTML usually loads fine.  I can read text without any problems, but it
seems to have difficult after loading one or two images.

- Unlike most other SSL sites, this server seems to have a problem with its
certificate.  I get a warning indicating that Mozilla cannot verify the identity
of the site.  Verbatim:

"Unable to verify the identity of www.ntcgl.navy.mil as a trusted site.

Possible reasons for this error:
- Your browser does not recognize the Certificate Authority that issued the
site's certificate.
- The site's certificate is incomplete due to a server misconfiguration.
- You are connected to a site pretending to be www.ntcgl.navy.mil, possibly to
obtain your confidential information.

Please notify the site's webmaster about this problem."

This is the only apparent difference between this site (which does not work) and
other SSL sites (which work just fine)

Comment 4

16 years ago
Reporter, can you check your cache settings, and make sure that disk cache is
not set to zero? For me, after accepting the server certificate from the
Certificate Authority (that is not built in to Mozilla), the page loads fully in
about a second.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.