Closed Bug 18380 Opened 20 years ago Closed 20 years ago

Horizontal scrolling is not possible using the arrow keys

Categories

(SeaMonkey :: General, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 7404

People

(Reporter: snair, Assigned: mjudge)

References

()

Details

It is not possible to use the arrow keys for horizontal scrolling. I am using
the M10 build on a Windows 98 PC.
Also, supposing that I slide the scrollbar to the right using the mouse, if I
use the the down arrow key for scrolling down to the next line, the horizontal
scrollbar automatically resets to postion 0 on the new line.
Assignee: shuang → don
It should work like today's 4.x. Don, any one in your group?
cc lake on this one, too since she is working on keyboard nevigation spec.
Not being able to scroll horizontally w/ the left and right arrow keys is
covered in bug 7404
Resetting of the horizontal scrollbar to zero when scrolling vertically is
covered in bug 66
I don't know why Bugzilla is truncating my comments:
Resetting of the horizontal scrollbar to zero when scrolling vertically is
covered in bug 6633
Assignee: don → hyatt
this is a dup of a bug hyatt has, I think it's been fixed.
hyatt, can you help me find the dup?
Status: NEW → ASSIGNED
Target Milestone: M15
Sure enough, this is fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
D'oh. never mind.  Hey, mjudge or akkana, shouldn't you just be adding some key 
binds into browserBindings.xul?

Passing off to akkana.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Giving to akkana.  I'm assuming there are just no key binds in 
browserBindings.xul for left/right scrolling.
Assignee: hyatt → akkana
Status: ASSIGNED → NEW
Passing along to saari.  The browser bindings are busted, have been since the
New Year's break; copy and page up/down don't work either (separate bugs already
filed for those issues).
Assignee: akkana → saari
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback
akkana, the other bindings are firing now, so I'm tossing this back at you. If
there is still something on my end that is blocking this, do tell
Assignee: saari → akkana
Target Milestone: M15
Akkana -- I'm setting this to M14 just in case you get a chance to look at 
before Wednesday, otherwise we can move it over to M15
Target Milestone: M14
I will look at it.  There are a bunch of other key bindings (like ^B in the
editor) also not working; might be related.
Looks like horizontal scrolling was never implemented in the browser controller
(dom/src/base/nsGlobalWindow.cpp).  I'll try to figure out how this should be
implemented if there's time after the beta1 bugs.
Status: NEW → ASSIGNED
OS: Windows 98 → All
Hardware: PC → All
Mike said I should assign this to him.
Assignee: akkana → mjudge
Status: ASSIGNED → NEW
spam: added self to cc list as this affects my area.

nominating for beta1 --but is it necessary?
Keywords: beta1
Whiteboard: [PDT-]
CCing to me, sorry for the spam
move to M15 due to PDT-
Target Milestone: M14 → M15
do you have this fix?
Keywords: beta1
Priority: P3 → P1
Whiteboard: [PDT-]
resolving this as a duplicate of #7404 since that bug has a patch attached


*** This bug has been marked as a duplicate of 7404 ***
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
'kay.
Status: RESOLVED → VERIFIED
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.