Crashing at start-up due to bookmarks.html file

VERIFIED FIXED in M12

Status

()

Core
RDF
P3
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: johng, Assigned: scottputterman)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Johng is crashing at start-up. We have determined that the cause is his 4.x
bookmarks.html which is migrated over at start-up. If we delete it, then he
starts up ok.

The trace is in Frame Manager, but I chose the component as RDF since it is
bookmark related.

To reproduce:

1. Create a profile then shutdown.
2. Copy the bookmarks.html file located at
http://slip/projects/dogbert/test/install into the newly created profile
directory.
3. Launch

Results: you will crash with the stack trace below.

This is using a Nov. 9 build, and has been happening for quite awhile.


   0x0a9b0278


   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1467]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   FrameManager::RestoreFrameState

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1474]

   PresShell::ContentAppended

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1889]

   nsDocument::ContentAppended

[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 1511]

   nsHTMLDocument::ContentAppended

[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line
994]

   HTMLContentSink::NotifyAppend

[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp,
line 3473]

   SinkContext::CloseContainer

[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp,
line 1248]

   HTMLContentSink::CloseContainer

[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp,
line 2549]

   CNavDTD::CloseContainer

[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 2736]

   CNavDTD::CloseContainersTo

[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 2773]

   CNavDTD::CloseContainersTo

[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 2815]

   CNavDTD::HandleEndToken

[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1494]

   CNavDTD::HandleToken

[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 654]

   CNavDTD::BuildModel

[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 463]

   nsParser::BuildModel

[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1049]

   nsParser::ResumeParse

[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 961]

   nsParser::OnDataAvailable

[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1336]

   USER32.dll + 0x12f5 (0x77e712f5)

Updated

19 years ago
Assignee: waterson → rjc

Comment 1

19 years ago
can you look at this one?

Updated

19 years ago
Severity: normal → critical
Target Milestone: M11

Comment 2

19 years ago
Putting on M11 radar while investigating.  paulmac, let us know if this could be
a Release Note.

Updated

19 years ago
Assignee: rjc → putterman

Comment 3

19 years ago
Below is the stack trace I'm getting on the crash. It looks like its crashing on
a "mailbox:" URL that johng has in his bookmarks... and mail/news is choking on
it.

The URL is:
"mailbox:/C|/Program
Files/Netscape/Users/johng/mail/Inbox?id=C32EE7CBC436D21196EA00805FA7F6A60D826B%
40ptmsg1.hq.navy.mil&number=16254696&part=1.2"

Reassigning this one to putterman.

nsUnescapeCount(char * 0x00000000) line 145 + 3 bytes
nsUnescape(char * 0x00000000) line 134 + 9 bytes
nsMsgLocalMailFolder::GetIncomingServerType() line 1843 + 16 bytes
nsMsgFolder::Init(nsMsgFolder * const 0x024c66b0, const char * 0x024c69c0) line
175 + 15 bytes
nsMsgLocalMailFolder::Init(nsMsgLocalMailFolder * const 0x024c66b0, const char *
0x024c69c0) line 193 + 14 bytes
RDFServiceImpl::GetResource(RDFServiceImpl * const 0x00d071e0, const char *
0x024c69c0, nsIRDFResource * * 0x008edea4) line 662 + 16 bytes
BookmarkParser::AddBookmark(nsCOMPtr<nsIRDFContainer> & {...}, const char *
0x024c69c0, const unsigned short * 0x008ee258, int 917983211, int 0, int 0,
const char * 0x024c59e0, nsIRDFResource * 0x024186a0, nsIRDFResource * *
0x008ee844) line 1039 + 45 bytes
BookmarkParser::ParseBookmark(const nsString & {...}, nsCOMPtr<nsIRDFContainer>
& {...}, nsIRDFResource * 0x024186a0, nsIRDFResource * * 0x008ee844) line 903 +
71 bytes
BookmarkParser::Parse(nsIRDFResource * 0x024c4110, nsIRDFResource * 0x024186a0)
line 596 + 59 bytes
BookmarkParser::ParseBookmarkHeader(const nsString & {...},
nsCOMPtr<nsIRDFContainer> & {...}, nsIRDFResource * 0x024186a0) line 1219 + 27
bytes
BookmarkParser::Parse(nsIRDFResource * 0x024c1b40, nsIRDFResource * 0x024186a0)
line 607 + 29 bytes
BookmarkParser::ParseBookmarkHeader(const nsString & {...},
nsCOMPtr<nsIRDFContainer> & {...}, nsIRDFResource * 0x024186a0) line 1219 + 27
bytes
BookmarkParser::Parse(nsIRDFResource * 0x02419560, nsIRDFResource * 0x024186a0)
line 607 + 29 bytes
nsBookmarksService::ReadBookmarks(nsBookmarksService * const 0x024195a0) line
3355
nsBookmarksService::Init() line 1561 + 12 bytes
NS_NewBookmarksService(nsISupports * 0x00000000, const nsID & {...}, void * *
0x008ef314) line 2318 + 8 bytes

Comment 4

19 years ago
Yes, it is release-notable, as there is a work around.

BTW, I pasted the wrong stack trace in, sorry. Please ignore it.

Updated

19 years ago
Target Milestone: M11 → M12

Comment 5

19 years ago
moving to m12.  paulmac can you get the release note item in...

Comment 6

19 years ago
done
(Assignee)

Comment 7

19 years ago
Seth, does the patch you checked into nsMsgFolder.cpp today fix this?
I bet it does.

I'll try to reproduce it by having mailbox url in my bookmarks.
better yet, I'm attempting to reproduce with johng's bookmarks.

looking at his bookmarks, I'm seeing another bug:

we need to migrate any mailbox:// urls in bookmarks.

"mailbox:/C|/Program
Files/Netscape/Users/johng/mail/Inbox?id=C32EE7CBC436D21196EA00805FA7F6A60D826B%
40ptmsg1.hq.navy.mil&number=16254696&part=1.2"

is a 4.x style url.

we need to migrate that to

mailbox://johng@nsmail-2/Inbox?id=C32EE7CBC436D21196EA00805FA7F6A60D826B%40ptmsg1.hq.navy.mil&number=16254696&part=1.2

(assuming his mail server is nsmail-2)

I'll log that bug next.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
with his bookmarks.html file, I am not seeing the crash.

marking this fixed.

johng, try a more recent build and re-open if it still crashes for you.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
also verified with johng's bookmarks - 2000010308
You need to log in before you can comment on or make changes to this bug.