Closed Bug 1838455 Opened 9 months ago Closed 9 months ago

startup Crash in [@ nsAppShellInit]

Categories

(Core :: Widget: Win32, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1571516
Tracking Status
firefox-esr102 --- unaffected
firefox114 --- wontfix
firefox115 --- wontfix
firefox116 --- wontfix

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: crash)

Crash Data

1000-1500 crashes per release cycle, almost all reports on Windows (different OS versions)

Crash report: https://crash-stats.mozilla.org/report/index/991bc689-3a9d-4339-a598-5d7450230614

MOZ_CRASH Reason: MOZ_RELEASE_ASSERT(((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))))

Top 10 frames of crashing thread:

0  xul.dll  nsAppShellInit  widget/nsAppShellSingleton.h:47
0  xul.dll  nsWidgetWindowsModuleCtor  widget/windows/nsWidgetFactory.cpp:49
1  xul.dll  mozilla::xpcom::CallInitFunc  xpcom/components/StaticComponents.cpp:9675
1  xul.dll  mozilla::xpcom::CreateInstanceImpl  xpcom/components/StaticComponents.cpp:10730
2  xul.dll  mozilla::xpcom::StaticModule::CreateInstance const  xpcom/components/StaticComponents.cpp:13348
2  xul.dll    xpcom/components/nsComponentManager.cpp:184
2  xul.dll  nsComponentManagerImpl::GetServiceLocked  xpcom/components/nsComponentManager.cpp:971
3  xul.dll  nsComponentManagerImpl::GetService  xpcom/components/nsComponentManager.cpp:1025
4  xul.dll  CallGetService  xpcom/components/nsComponentManagerUtils.cpp:51
4  xul.dll  nsGetServiceByCIDWithError::operator const  xpcom/components/nsComponentManagerUtils.cpp:227

Stephen, could you check what's causing the startup crashes? Thanks in advance.

Flags: needinfo?(spohl.mozilla.bugs)

This seems to be a continuation of the conversation in bug 1545381. n-i the folks who were involved in the discussion there.

Component: Widget → XPCOM
Flags: needinfo?(spohl.mozilla.bugs)
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(froydnj+bz)
See Also: → 1545381

(In reply to Stephen A Pohl [:spohl] from comment #2)

This seems to be a continuation of the conversation in bug 1545381. n-i the folks who were involved in the discussion there.

I don't think this is related. That crash was in nsWidgetWindowsModuleDtor when we shut down in the middle of startup. This is in nsWidgetWindowsModuleCtor, when nsAppShellInit fails. I'm not sure why that's happening. We should maybe just release assert success in the app shell init rather than returning failure and asserting success later. But that isn't really my area.

Also clearing Nathan's NI. He doesn't work here anymore.

Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(froydnj+bz)

It looks like this is the same issue as bug 1571516.

A diagnostic patch in that bug added a diagnostic assert:
MOZ_DIAGNOSTIC_ASSERT(mEventWnd, "CreateWindowW for EventWindow failed");

We'd crash like the crash in this bug if that failed, and I don't see any crashes with this signature on Nightly, so I think it is the same issue.

Status: NEW → RESOLVED
Closed: 9 months ago
Component: XPCOM → Widget: Win32
Duplicate of bug: 1571516
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.