--enable-calendar does not work with --disable-mailnews

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: bugzilla, Assigned: mostafah)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021122
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021122

Comment from personal .mozconfig:

# --disable-mailnews does not work with enable_calendar?
# --enable-calendar requires nsMsgCompCID.h from C:\mozilla\mailnews\compose\build


Reproducible: Always

Steps to Reproduce:
1. Set up appropriate .mozconfig.
2. Build Mozilla
3.

Actual Results:  
The build stops and says "header file net found: nsMsgCompCID.h"

Expected Results:  
Completed a build.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Updated

16 years ago
Blocks: 182076
(Reporter)

Comment 1

16 years ago
Here's the actual error...

make[3]: Entering directory `/cygdrive/c/mozilla/calendar'
make[4]: Entering directory `/cygdrive/c/mozilla/calendar/libxpical'
oeICalEventImpl.cpp
Building deps for c:/mozilla/calendar/libxpical/oeICalEventImpl.cpp
cl -FooeICalEventImpl.obj -c -DOSTYPE=\"WINNT5.1\" -DOSARCH=\"WINNT\" -DOJI
-DWIN32_LEAN_AND_MEAN  -I../../dist/include/xpcom -I../../dist/include/appshell
-I../../dist/include/string -I../../dist/include/timer
-I../../dist/include/necko -I../../dist/include/msgcompose
-I../../dist/include/addrbook -I../../dist/include/ical
-I../../dist/include/icalss -I../../dist/include/calendar -I../../dist/include
-I../../dist/include/nspr           -TP -W3 -nologo -Gy -Fdxpical.pdb  -DDEBUG
-D_DEBUG -DDEBUG_Curtis -DTRACING -Zi -MDd           -DHAVE_MMINTRIN_H=1
-D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_PC=1 -DXP_WIN=1 -DXP_WIN32=1
-DHW_THREADS=1 -DWINVER=0x400 -DMSVC4=1 -DSTDC_HEADERS=1 -DNEW_H=\<new\>
-DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino
-DMOZ_DEFAULT_TOOLKIT=\"windows\" -DMOZ_ENABLE_COREXFONTS=1 -DIBMBIDI=1
-DACCESSIBILITY=1 -DMOZ_MATHML=1 -DMOZ_LOGGING=1 -DDETECT_WEBSHELL_LEAKS=1
-DMOZ_USER_DIR=\".mozilla\" -DCPP_THROW_NEW=throw\(\) -DMOZ_XUL=1
-DINCLUDE_XUL=1 -DNS_MT_SUPPORTED=1 -DUSE_IMG2=1 -DMOZ_DLL_SUFFIX=\".dll\"
-DXP_PC=1 -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1
-DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1  -DMOZILLA_CLIENT -DICAL_DEBUG 
c:/mozilla/calendar/libxpical/oeICalEventImpl.cpp
oeICalEventImpl.cpp
c:/mozilla/calendar/libxpical/oeICalEventImpl.cpp(51) : fatal error C1083:
Cannot open include file: 'nsMsgCompCID.h': No such file or directory
make[4]: Leaving directory `/cygdrive/c/mozilla/calendar/libxpical'
make[3]: Leaving directory `/cygdrive/c/mozilla/calendar'
make[2]: Leaving directory `/cygdrive/c/mozilla'
make[1]: Leaving directory `/cygdrive/c/mozilla'
Ending build: 
Sat Dec  7 06:12:07  2002
The only thing we can do from a build config standpoint is add a check to stop
the build if that combination of options is specified.  If you want to actually
be able to build calendar w/o mailnews then either the calendar guys need to
remove the dependency or the mailnews guys need to make those headers available
outside of the mailnews tree.
(Assignee)

Comment 3

16 years ago
I think we can make the dependancy on mailnews optional.
Taking bug
Assignee: seawood → mostafah
Component: Build Config → libxpical
Product: Browser → Calendar
Version: Trunk → unspecified
(Assignee)

Comment 4

16 years ago
Created attachment 108756 [details] [diff] [review]
Patch to make calendar dependant on mailnews only if it exists

The code that adds mailnews dependancy is now between #ifdef MOZ_MAIL_NEWS
blocks.
Does this need review to be checked in?
Hrm.  Is that really what we want?  For awhile, we were avoiding having cpp
defines for large features like mail/news.  The behavior of the rest of the app
should not change if mail/news wasn't compiled in initially since we support
dropping in a mail/news xpi after the initial install.
(Assignee)

Comment 6

16 years ago
If the patch ( attachment 108756 [details] [diff] [review] ) is checked in, this bug would not block bug
182076 anymore which is almost to be closed, however it should remain open to
deal with the issues stated in comment #5.
IMO, this isn't a real blocker for landing calendar.  I'm guessing that the
subset of people who want calendar but not mailnews is small.  And I would like
this fixed correctly because once it goes in, it probably won't be fixed in any
timely manner despite causing problems by not properly rebuilding if you switch
between --enable/disable-mailnews.   Chances are that it'll be one of those
"temporary" fixes that's in the tree for 3 yrs.  I want to avoid that.

Updated

16 years ago
No longer blocks: 182076
(Assignee)

Comment 8

16 years ago
Created attachment 109239 [details] [diff] [review]
Patch v2.0 with cvs diff -u30

Patch with more detail in its diff
Attachment #108756 - Attachment is obsolete: true
(Reporter)

Comment 9

16 years ago
It's been a bit, and I've been thinking that an acceptable fix would be in two
parts:

1) make BUILDING (i.e. "Browser/Build Config") require mailnews to be enabled if
calendar is. It's fair enough to make that a documented requirement.

2) make RUNNING (i.e. "Calendar/libxpical") NOT require mailnews in order to
run, by returning NS_ERROR_NOT_IMPLEMENTED in routines that require mailnews
when mailnews is not available (determined by a QI to the appropriate interface
at runtime, not by a build flag at compilation time.)
(Assignee)

Comment 10

15 years ago
*** Bug 234868 has been marked as a duplicate of this bug. ***
Mostafah, is this still an issue now that libxpical is obsolete?
Can this bug and the other 11 libxpical bugs be closed now?
WFM now that libxpical is obsolete.
I'm building Sunbird here explicitly with disable-mailnews set and it works quite well under Windows XP.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
QA Contact: granrosebugs → nobody
Mass move of libxpical bugs to the Internal Components, per ctalbert.
Component: libxpical → Internal Components
The bugspam monkeys have been set free and are feeding on Calendar :: Internal Components. Be afraid for your sanity!
QA Contact: nobody → base
You need to log in before you can comment on or make changes to this bug.