Mozilla doesn't integrate with OS and ignores user set choices.

RESOLVED DUPLICATE of bug 108455

Status

--
major
RESOLVED DUPLICATE of bug 108455
16 years ago
14 years ago

People

(Reporter: mozilla, Assigned: bnesse)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

Mozilla ignores user choices in OS's that have standard mechanism to support
client choice configuration.

Under Internet properties control panel in Win, you can set clients for news,
composer, mail and browser.  Mozilla ignores these preferences.

I'm filing this in the 'backend' of user-prefs, since storing and reading
preferences on startup should 'do the OS-specific "right thing"' and read/write
preferences for mailer, news, browser, composer, address book, etc, from
the registry on Win(98-XP).  

Everyone talked about how bad it was when MS ignored and overwrote user prefs,
but even before the recent monopoly rulings, MS had fixed those problems.

This is also a problem on updates -- when I upgraded, IE and Mozilla recently,
it was Mozilla that overwrote my perferences, not IE.  That's not being a
community player -- just because MS has been bad in the past doesn't mean we
should follow their example in badness.

However on those OS's that don't support a common registry/unified format
for doing things, maybe MS's idea of a registry isn't such a bad idea afterall.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
-> invalid

Mozilla asks your if Mozilla should to be the default browser and mail client
for your OS.
You can set mozilla that it never ask again. (and it will set Mozilla again as
default browser if another Browser is the default without asking)
You would not get this if you wouldn't check this checkbox.

And talking about MS and/or IE doesn't belong in a bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
So talking about OS specific bugs or other browsers doesn't belong in
a bug report?  I've seen comments about Linux, Macintosh, and if I 
searched enough, I'm sure I'd find references to Opera somewhere as well.

The bug is not invalid.

Mozilla asks the question and I say 'no'.  Yet when I am reading news and
click on a link, it uses mozilla as my default browser.

When I am in mozilla, even though I said 'no' to use it for email, it 
still uses it in email.  

Saying that mozilla has a bug in not respecting user choices is somehow
'invalid' and I'm not allowed to find fault with mozilla being OS
incompatible is incredibly biased. and doesn't resolve the bug.

Status: RESOLVED → UNCONFIRMED
Component: Preferences: Backend → Preferences
Resolution: INVALID → ---
What do you mean ?
Do you mean : 
You click a link in mailnews and it should open the default browser for this link?
And if you click a mailto: link in the browser it should open your default mail
client ?

Something like this doesn't belong in a bug report:
>Everyone talked about how bad it was when MS ignored and overwrote user prefs,
>but even before the recent monopoly rulings, MS had fixed those problems.
(Reporter)

Comment 4

16 years ago
Exactly.  Instead of the below behavior, when I click a link a mailto:link in 
mozilla, it opens the mozilla mail-handler.  If I click a browser link in the 
news client, it opens the link with mozilla not IE.  

Most of my news reading is in the ms news groups (not many choices for getting 
info and MS people do participate in the groups...(I hate closed source!!! -- 
especially undocumented features...I really hate MS...but that doesn't mean 
while fighting the battle I may not use the most convenient tool for the job.

For example...simple detail.  If I have a mozilla-email compose window open 
and an outlook compose window open, I can drag and drop selected text from 
outlook into the mozilla window, but I can't go the other direction.  Simple 
things like that are frustrating.  

I wouldn't expect clicking on a browser link in mozilla to open IE (sorta self 
defeating), but if I open a different client type (mail, addr book, chat, 
news, browse, virtual sex...whatever, it should choose the client I have 
selected -- but only at the logical transition points.  

It may be totally silly to expect, but if I configure email with eudora, news 
with mozilla and browse with IE, I'd want them all to work together when they 
call a different client type.  Probably telnet as well -- should call up 
my 'securecrt' app.  Everything plug and playing together then everyone gets 
what we all want -- 
*choice*.  Each client can woo their particular users in their own way -- and 
people will have favorites and preferences...a Uniform, everything mozilla is 
no more appealing than a uniform everything MS.  That's the whole idea behind 
the breaking apart issues against MS.  They wanted to bundle everything as a 
lump with the OS. But software vendors want users to be able to choose what 
they want for music play, CD recording, all those things.  

I want Mozilla to play in the same playground with everyone else.

I'm getting a bit **** at the linux community because so many of them are so 
damn evangelical they can't consider any options or idea from close-source -- 
samba being a notable exception.  But using the user-chosen clients for the 
different protocol types...

You know, I'm actually a bit torn -- purist wise.  The purist in me think that 
if I am so stupid to open IE (or Mozilla) to view a web page, that if I click 
on a link, it should still check the standard protocol handler at each click.  
Probably not what the user wants -- but who knows?  If they want to try out a 
different 
browser, maybe they should be forced to choose it if they want to  stay in the 
same browser....but that's probably a bit fascist...(it’s the technical purist 
in me).

Am I getting to be better understood?
(I hope?)
Linda W


why this long discussion ?
The bug summary should be "Browser doesn't use default mailer" and a second bug
for "Mozilla Mail doesn't open default Browser"

You must not write such a long story.
I misunderstand your initial bug report(I thought mozilla reassigned the default
Browser from IE to Mozilla after an install)

Mozilla doesn't open the default handler because it's a missing feature !
(and not that we don't want this).
This also means that "severity" would be "enhancement" but this is of course
already reported.

bug 108455 "Mozilla mail doesn't open URLs in system default browser"
bug 11459  "need option for mailto: to launch external mail app or open a
webmail url"

and since we are open source we also accept patches if you want to implement this.

btw: see bug 177513 how this bug report could look :-)

marking as dupe of bug 108455


*** This bug has been marked as a duplicate of 108455 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
QA Contact: sairuh → pmac
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.