Closed Bug 1839888 Opened 1 year ago Closed 1 year ago

[macOS] Wrong error displayed when importing bookmark HTML files with no reading permissions

Categories

(Firefox :: Migration, defect)

Firefox 116
Desktop
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1839827
Tracking Status
firefox-esr102 --- unaffected
firefox114 --- unaffected
firefox115 --- unaffected
firefox116 --- fixed

People

(Reporter: atrif, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Attached video wrongerror.mov

Found in

  • 116.0a1 (2023-06-22)

Affected versions

  • 116.0a1 (2023-06-22)

Tested platforms

  • Affected platforms: macOS 12
  • Unaffected platforms: Windows 10x64, Ubuntu 22.04

Preconditions

  • open terminal and type chmod 266 and drag and drop the bookmark file that we need to set no permissions to (e.g chmod 266 Users/svuser/Documents/bookmarksfile.html)

Steps to reproduce

  1. Import the bookmark.html file from preconditions using the new migration window.

Expected result

  • An error that the file has no read permissions is displayed.

Actual result

  • xmlhttpprequest failed error is displayed.

Regression range

  • Most likely not a regression but I will search for one to be sure.

Additional notes

  • Attached a screen recording.
  • On Windows 10x64 and Ubuntu 22 a system error is displayed saying that the file does not have read permissions
  • On Firefox 115.0b8 there is an infinite loading window displayed (see bug 1839887)

This appears to be a general issue where we're using the exception message as the contents of the error.

Status: NEW → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1839827
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: