Closed Bug 183992 Opened 17 years ago Closed 16 years ago

The 'cc' field needs to stop using %::FORM

Categories

(Bugzilla :: Creating/Changing Bugs, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 161203

People

(Reporter: erik, Assigned: erik)

Details

The 'cc' field uses the old %::FORM hash for its input, which worked fine until
the substring/wildcard match started creating multiple instances of 'cc' in its
field elements.

The problem is that %::FORM elements are concatenated from all instances, so
when these multiple instances are sent, say, as "not_erik@dasbistro.com" and
"bugreport@peshkin.net", $::FORM{'cc'} will contain
"not_erik@dasbistro.combugreport@peshkin.net".

For now, the 'cc' field seems to be the only one actually affected by this, so
it's more of a priority to have it weaned from %::FORM than the other fields. 
But the other instances of %::FORM should be taken care of too.

Per a discussion with bbaetz and justdave on #mozwebtools, the right way to do
this seems to be changing it to use $cgi->param(), which is where everything
should be headed.
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18
Erik, can you clarify the symptom of your problem? How do you produce input via
Bugzilla that gets run into itself like that?
kiko: what's really being said here is that it should have been using %::MFORM
instead of %::FORM, but since we're going to touch it anyway because of the CGI
conversion, we might as well do it with CGI.

This already got fixed though... (with the MFORM method)


*** This bug has been marked as a duplicate of 161203 ***
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
No longer depends on: 225818
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.