Closed Bug 1840855 Opened 8 months ago Closed 5 months ago

Make togglePopover throw more exceptions

Categories

(Core :: DOM: Core & HTML, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1842845

People

(Reporter: jarhar, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/115.0.0.0 Safari/537.36

Steps to reproduce:

const popover = document.createElement('div');
popover.setAttribute('popover', 'auto');
// don't connect to document
popover.togglePopover();

Actual results:

No exception gets thrown

Expected results:

An exception should be thrown.

I am changing this in the HTML spec here: https://github.com/whatwg/html/pull/9451
And here is a WPT for the change: https://github.com/web-platform-tests/wpt/pull/40682

The Bugbug bot thinks this bug should belong to the 'Core::DOM: Core & HTML' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core
Blocks: popover
Severity: -- → S3
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Duplicate of bug: 1842845
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.