Chimera cuts out end of mouse-over animation

RESOLVED FIXED

Status

Camino Graveyard
General
--
minor
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Gabriel Bender, Assigned: Simon Fraser)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021207 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021207 Chimera/0.6+

When I put the mouse over the "Parties" link at
http://www.mozilla.org/start/1.0/ there should be an animation of a balloon
flying around and exploding. The end of the animation, where the balloon
explodes, is not displayed. This worked in the 11/28/02 nightly build but no
longer works in the 12/7/02 nightly build. The animation did not work correctly
before I downloaded the 11/28 nightly build. Note that the 11/28 nightly build
was programmed to redisplay the web page every .2 seconds. After this build, the
time was changed to .5 seconds. So I suspect that this has something to do with
the problem. The javascript source code for the animation is available at the
following address:

http://www.mozilla.org/start/1.0/fireworks.js

Reproducible: Always

Steps to Reproduce:
1. Load the web site http://www.mozilla.org/start/1.0/
2. Place the mouse over the "Parties" link
3. The end of the "fireworks" animation is cut off.
Actual Results:  
An animation of a ball moving around the screen and exploding should be displayed.

Expected Results:  
The frames at the end of the animation, where the ball explodes, are not displayed.
(Assignee)

Comment 1

15 years ago
This works for me now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

15 years ago
Reporter states that the bug still occurs on a 400MHz iMac. Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

15 years ago
Confirming.... I'm seeing the problem on 2003012707... 400mhz g4 powerbook 1gb ram 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
not sure why that doesn't show, but it also doesn't work on my 500MHz TiBook.
Note that it works okay in Mozilla trunk on the same machine. I wast talking to
pinkerton about another example today and it sounds like chimera may have some
speed/updating issues compaired to mozilla with dynamic content
Assignee: saari → sfraser

Comment 5

15 years ago
I appear to be seeing the entire fireworks animation on rollover of "Party" with
Camino 2003041005 just as I am in Moz 2003041008

WFM?
(Reporter)

Comment 6

15 years ago
Chris, I suspect that this has something to do with the speed of the user's computer. The two people who experienced this problem had an iMac G3 400Mhz and a Powerbook G4 400Mhz. It's probably an issue that's specific to older, slower machines. Having Quartz Extreme on OS X 10.2 might also help.

Comment 7

15 years ago
um... ok...

But *I am* the one on the powerbook that confirmed this bug in comment 3 and i'm
on the same machine with no hardware tweaks since.

A lot has changed in Camino since 1/27, including getting on the trunk. As the
other confirmer, Gabriel, mind looking at it in a nightly build and reporting back?

(As for quartz extreme - Rev A G4 powerbook w/ ATI Rage Mobility 128 - so I
can't run it on this vid card... grrr)
(Reporter)

Comment 8

15 years ago
OK, this seems to work for me too, now (Mozilla build 2003041205). I think that the bug status 
should probably be changed to "fixed" at this point. Thanks, Chris, Simon, saari@netscape.com, 
and everyone involved in migrating the bug fixes and updates from the Mozilla trunk (I suspect 
that this is what fixed the problem).
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.