text-fields (input type="text") don't work corectly within my drag&drop-able div-tag.

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
15 years ago
10 years ago

People

(Reporter: Sebastian, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

I have constructed a kind of "modular dialog". It consists of few div-tags. One
for the status bar to drag&drop the dialog and 2 div-tags for content. the
content-div tags contain several nested tables. I have problems to insert a
form. an input (type="text") tag don't work correctly within the dialog. the
text-field cannot be marked by left mouse click as usual. Only with a right
click a cursor occurs in the text field. But this isn't acceptable.

Reproducible: Always

Steps to Reproduce:
1.drag mouse over main-button in navigation bar
2.click NAV1
3.a drag&drop-able dialog occurs. the text field doesn't work as desired

Actual Results:  
a blinking cursor remains on the text-field's position (before dragging) after
closing the dialog.

Expected Results:  
the input tag (and all forms) should be marked by left click. the input tag
should work correctly.
Are you cancelling all click events to everything in that div?  That's what it
looks like....
Summary: text-fields (input type="text") don't work corectly within my drag&drop-able div-tag. → text-fields (input type="text") don't work corectly within my drag&drop-able div-tag.
You're cancelling the mousedown event on anything in the document. We focus the
textfield on mousedown (that's the only way that makes sense when you think
about it).  So you're cancelling the textfield being focused...
Mass-reassigning bugs.
Assignee: jst → dom_bugs

Comment 4

15 years ago
Sebastian could you update this bug please? Is bz's analysis correct?
This is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.