Closed Bug 1841423 Opened 10 months ago Closed 9 months ago

Delete a message with delete or Shift+Delete and the message list is not updated

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 116
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1842126

People

(Reporter: ali-savas, Unassigned)

References

Details

(Keywords: access, regression)

After a week break, yesterday I updated to version 116.0a1 (2023-06-30) (64-bit). Since then, I've had the problem that when a message is deleted with Shift+Delete, the message list doesn't refresh until Down Arrow and Up Arrow are pressed. However, this only seems to be the case for the screen reader. I don't know when this functionallity broke again. This Bug was fixed with bug 1825588.

Note: I also had this problem briefly last night, however I was unable to reproduce it for a while. So it doesn't seem to occur all the time, currently it occurs all the time for me though.

Steps to reproduce

  • Focus the message list.
  • Press Shift+Delete to delete a message.

Result.

The message is deleted, but the message list is not updated with the next message that was selected. Only after arrow down and arrow up has been pressed, the next message is announced by the screen reader. Since I get a message from the screen reader that the next focused message is a junk message, I assume that the list is not being updated correctly for the screen reader only.

Expected

After deleting the selected message, the next message should be announced.

Keywords: access, regression
Summary: Delete a message with Shift+Delete and the message list is not updated → Delete a message with delete or Shift+Delete and the message list is not updated

I just updated to version 116.0a1 (2023-07-01) (64-bit). Here everything seems to work as usual again. However, I want to observe it a bit before closing this bug again.

I can reproduce this problem everywhere. It has nothing to do with any particular email provider.

If I press Delete or Shift+Delete to delete the message, the next selected message is now announced to me. However, every now and then it still happens that the next but one message is not announced again when I press Delete or Shift+Delete to delete it.

Please have a look at this problem again.

Sorry to ask again so soon, but bug 1842126 was fixed in July 8 build, five days ago. Are you still seeing thei issue?

Flags: needinfo?(ali-savas)
See Also: → 1843071, 1843462
See Also: → 1840787

Sorry to ask again so soon, but bug 1842126 was fixed in July 8 build, five days ago. Are you still seeing thei issue?

No problem at all!

It does seem that the bug has been fixed. To be 100% sure, I would like to try it again. Since I'm out of town for the weekend, I'll be able to give an answer on Monday at the latest.

Flags: needinfo?(ali-savas)

Unfortunatelly I was not able to follow all the updates to this as these were happening recent two weeks however by testing with the current 116 build on linux, the original issue where deleting a message should focus a new message and that change should get reported to screen readers is definatelly fixed at least I haven't noticed problems with it today when testing specifically for this.

Closing this because we want to have a tight grip on this area of message list behavior, especially in these early weeks of 115. We don't want other users to sign up to bug reports which likely no longer exist for 116 and 115. We can reopen the bug if testing determines the problem is not gone.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1842126
Flags: needinfo?(rogersteve2022)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.