CPU usage pins at 100% until Mozilla killed when opening www.salon.com

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: cwassman, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Searching for salon.com yielded a similar 'unconfirmed' hit in bug number
184035. but this was for a much older mozilla build, Mozilla/5.0 (Macintosh; U;
PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6 and on a different
platform.

Doubt my problem is flash related however as when I disable javascript in
Navigator the problem disappears.

Reproducible: Always

Steps to Reproduce:
1. Enable javascript for navigator.
2. Type in url: http://www.salon.com
3. Watch as CPU usage pins to 100% and you have to kill mozilla.exe

Actual Results:  
*-CPU usage pins to 100%
*-Mozilla becomes completely unresponsive, unable to manipulate GUI at all.
*-'M' icon in upper right does not return, stays in 'loading state' but
animation stops.



Expected Results:  
Load page, report javascript errors if there are any.

First saw error in 1.2 , just downloaded 1.2.1 and error still occurs, no
similar bugs found that I can see.
(Reporter)

Comment 1

16 years ago
Actually this is possibly flash related as there seems to be a flash object
written conditionally by some javascript code on the page.

I'm going to attach a copy of the page which produces this effect in case the
www.salon.com page changes and the bug disappears.
(Reporter)

Comment 2

16 years ago
Created attachment 108633 [details]
snapshot of www.salon.com that produces this bug.

Comment 3

16 years ago
What a well-written bug report!

I am unable to hang on the snapshot using a trunk Mozilla build
dated 2002-12-04 on WinNT. I'm going to reassign this to Plug-ins
in case this does have to do with the Flash object here.

I don't think it's JS Engine, since otherwise we'd have a lot more
reports on this popular site. 

Note the recently-resolved bug 58339,
"Flash plugin (presumably 5.0 r47 - r50 only) hangs Mozilla,
when it's trying to play audio, while audio device is active."

I believe the solution there was to get Flash 6 instead of Flash 5.
Chris: what version of Flash does Mozilla show? (Help > About Plug-ins)
Assignee: rogerl → beppe
Component: JavaScript Engine → Plug-ins
QA Contact: pschwartau → shrir
Summary: With JavaScript enabled, CPU usage pins at 100% until mozilla killed when opening www.salon.com → CPU usage pins at 100% until Mozilla killed when opening www.salon.com
(Reporter)

Comment 4

16 years ago
viola!

I was using:
Shockwave Flash 3.0 r8

I installed:
Shockwave Flash 6.0 r47

and my CPU no longer pins to 100%.

I imagine no one cares to use such an old version of flash, normally I'd expect
to be redirected over to macromedia for new download, but perhaps salon.com's
flash code is sloppy.  I'm not sure if its salon or mozilla's responsibility at
this point.

Regardless, installing latest flash download fixed the problem.

Cheers,
chris

Comment 5

16 years ago
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.