Closed Bug 1841769 Opened 1 year ago Closed 2 months ago

Firefox does not show suggestions for the empty query when in search mode

Categories

(Firefox :: Address Bar, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
128 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- disabled
firefox115 --- disabled
firefox116 --- disabled
firefox117 --- disabled
firefox118 --- disabled
firefox127 --- disabled
firefox128 --- verified
firefox129 --- verified

People

(Reporter: danibodea, Assigned: yazan)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [sng-scrubbed])

Attachments

(1 file)

Found in

  • Beta v116.0b1

Affected versions

  • Nightly v117.0a1
  • Beta v116.0b1

Tested platforms

  • Affected platforms: Ubuntu 22, Windows 10
  • Unaffected platforms: -

Steps to reproduce

  1. Have some searching history with a chosen one-off.
  2. go to about:config and set browser.urlbar.update2.emptySearchBehavior set to 2
  3. Select a One-off by clicking it with an empty input

Expected result

  • Selected one-off is displayed in the address bar, with the search history expanded in a dropdown.

Actual result

  • The search history is not displayed.

Regression range

Component: Search → Address Bar

:daleharvey, since you are the author of the regressor, bug 1832060, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(dharvey)

Set release status flags based on info from the regressing bug 1832060

We should evaluate to remove the browser.urlbar.update2.emptySearchBehavior pref, especially with trending suggestions. It was likely a placeholder because we didn't have much better results to show for the empty string. Trending suggestions may be a better choice.
This requires some investigation to verify that the pref is indeed just a feature that didn't make the cut to release. We're not planning anything related to it at the moment.

Blocks: 1824965
Severity: S3 → S4
Priority: -- → P3
Whiteboard: [sng-scrubbed]

This bug seems to happen again in the first beta of 118 (v118.0b1) as it reproduced in 117.0b1, while it does not reproduce in builds v117.0b2 through v117.0b9.

Yeh we can review whether we want to keep the emptySearchBehaviour pref, its not a maintained pref at the moment so the prefs not working together is ok, will talk to product to determine whether we want to maintain this pref or strip it out.

Flags: needinfo?(dharvey)

Marking this as fixed by bug 1885897. Pref was removed from Fx.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Assignee: nobody → yalmacki
Depends on: 1885897
Target Milestone: --- → 128 Branch

Verified as fixed on Firefox 128.0b1 and Firefox Nightly 129.0a1 on Windows 10, Ubuntu 22, macOS 14.
Confirming that browser.urlbar.update2.emptySearchBehavior pref has been removed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: