If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Google steals input focus

VERIFIED DUPLICATE of bug 124750

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 124750
15 years ago
9 years ago

People

(Reporter: Mikel Ward, Assigned: jag (Peter Annema))

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
DESCRIPTION
When the Google search engine main page finishes loading, it takes the keyboard
input focus.  This is annoying, because I sometimes open and start using
another page before Google has finished loading, and half-way thru typing in
the second page, my input starts being entered in Google.

STEPS TO REPRODUCE
1. Open <http://www.google.com/> in a browser tab
2. Open a new tab and enter a new web page address that takes keyboard input
   (such as <http://bugzilla.mozilla.org/"> and begin typing in that field

NOTES
If you are on a fast connection, you may need to create some heavy network
load so that you can open the second page and begin typing there before
Google finishes loading.

EXPECTED BEHAVIOR
Input focus remains where it is (in the second tab).

NOTES
I suspect this is a problem with Mozilla's tabs not behaving like pages, but
someone might see this differently.  In any case, I doubt we can get Google to
change its approach.

A workaround might be to stop pages on other tabs taking input focus.

A solution might be for Mozilla to keep track of each tab's focused field,
and for this field to be activated when that tab is activated.

VERSION
Observed in Mozilla 1.2.1 (Xft build), however I expect this issue applies to
several builds and all platforms.
Dupe of 124750.

Comment 2

15 years ago
indeed.  dupe of "Other tab steals focus with javascript textbox.focus()"

*** This bug has been marked as a duplicate of 124750 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.