Javascript behaves incorrectly

VERIFIED DUPLICATE of bug 180767

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 180767
15 years ago
15 years ago

People

(Reporter: Charles Gaefke, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

On this web page, I can type in the destination phone number, but the "from"
field will only hold one character.  When I switched to IE 6.0 to see how it's
"supposed" to handle, I can type in the full address.  There is a "character
count" on the bottom of the form that is supposed to count the characters
entered.  I'd imagine that code is what's causing the strange problem in
Mozilla.  Note that if you hold down a key, it'll count.  It seems there is a
".seltext" that's triggering too quickly.

I'm not sure if it's a code problem on the web page or a javascript engine
problem in mozilla... but, as they say, "It works" in IE.

Reproducible: Always

Steps to Reproduce:
1.Go to web page.
2.Type in phone number 999-999-9999
3.Type in a "from".  

Actual Results:  
It'll only enter one character in the "from", unless you hold down a key, which
makes it hard to type.

Expected Results:  
Enter the name correctly and have the "character count" increment correctly.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 180767 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Verified Duplicate.

Charles: thank you for this report. You have been cc'ed
on bug 180767 so that you can follow progress on this -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.