If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

dotted, dashed, double, and outset borders not applied consistently to inlines

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Braden, Assigned: dcone (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

746 bytes, text/html
Details
(Reporter)

Description

18 years ago
The attached test case (to follow) tests the various border styles when applied
to the generic inline markup (SPAN). Styles noted in the summary fail. The
failure seems to be related to the fact that they are only being turn on for
part of the box.
(Reporter)

Comment 1

18 years ago
Created attachment 2750 [details]
Test case

Updated

18 years ago
Assignee: troy → dcone

Comment 2

18 years ago
Interesting test case. Thanks.

Comment 3

18 years ago
Don, this seems to be your department
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
The problem here was that the height that was being used was that of the top
border for the bottom. The bottom now uses the correct height.
The right and left had the same problem, and is now fixed also.
So that in these test cases the bottom would not show up.

Updated

18 years ago
QA Contact: petersen → chrisd

Comment 5

18 years ago
Tested and found that 'double' and 'outset' still not working. However, property
name was misspelled with outset and upon fixing that, no problem. Double is not
working with a 'thin' but it is working if you increase size to 'medium'. Is
this a new bug or part of the same? Please respond. Thanks
Thin borders are 1px wide, right, so double is somewhat meaningless, isn't it?
Anyway, see bug 1781 for "division of space within double borders."

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
Okay, verifying bug fixed.
You need to log in before you can comment on or make changes to this bug.