Build Fails: conflicting return types in nsBaseWidget::Enumerator::Next()

VERIFIED FIXED in M5

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: igb, Assigned: Chris McAfee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
/usr/local/gcc-2.8.1/bin/g++ -o nsComboBox.o -c -DXP_UNIX  -g  -fPIC
-DUSE_AUTOCONF=1 -DMOZILLA_CLIENT=1 -DBROKEN_QSORT=1 -DSTDC_HEADERS=1
-DHAVE_ST_BLKSIZE=1 -DHAVE_ST_RDEV=1 -DHAVE_TZNAME=1 -DHAVE_DIRENT_H=1
-DSTDC_HEADERS=1 -DHAVE_SYS_WAIT_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_FCNTL_H=1
-DHAVE_LIMITS_H=1 -DHAVE_MALLOC_H=1 -DHAVE_STRINGS_H=1 -DHAVE_UNISTD_H=1
-DHAVE_SYS_FILE_H=1 -DHAVE_SYS_IOCTL_H=1 -DHAVE_SYS_TIME_H=1
-DHAVE_SYS_CDEFS_H=1 -DHAVE_LIBC=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1
-DHAVE_LIBRESOLV=1 -DHAVE_LIBSOCKET=1 -DHAVE_LIBNSL=1 -DHAVE_LIBELF=1
-DHAVE_LIBINTL=1 -DHAVE_LIBPOSIX4=1 -DHAVE_LIBW=1 -DHAVE_LIBL=1
-DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -DHAVE_UNISTD_H=1 -DHAVE_GETPAGESIZE=1
-DHAVE_MMAP=1 -DRETSIGTYPE=void -DHAVE_STRCOLL=1 -DHAVE_STRFTIME=1
-DHAVE_UTIME_NULL=1 -DHAVE_VPRINTF=1 -DHAVE_FTIME=1 -DHAVE_GETCWD=1
-DHAVE_GETHOSTNAME=1 -DHAVE_GETWD=1 -DHAVE_MKDIR=1 -DHAVE_MKTIME=1
-DHAVE_PUTENV=1 -DHAVE_RMDIR=1 -DHAVE_SELECT=1 -DHAVE_SOCKET=1 -DHAVE_STRCSPN=1
-DHAVE_STRDUP=1 -DHAVE_STRERROR=1 -DHAVE_STRSPN=1 -DHAVE_STRSTR=1
-DHAVE_STRTOL=1 -DHAVE_STRTOUL=1 -DHAVE_UNAME=1 -DHAVE_QSORT=1 -DHAVE_SNPRINTF=1
-DHAVE_WAITID=1 -DHAVE_FORK1=1 -DHAVE_REMAINDER=1 -DHAVE_LCHOWN=1
-DHAVE_GETTIMEOFDAY=1 -DGETTIMEOFDAY_TWO_ARGS=1 -DHAVE_IOS_BINARY=1
-DHAVE_IOS_BIN=1  -UDEBUG -DNDEBUG -DTRIMMED -DNETSCAPE -DOSTYPE=\"SunOS5\"
-DMOZILLA_CLIENT -DLAYERS -DUNIX_EMBED -DX_PLUGINS -DJS_THREADSAFE
-DUNIX_ASYNC_DNS -DSTANDALONE_IMAGE_LIB -DMODULAR_NETLIB
-DMOZ_USER_DIR=\".mozilla\" -D_IMPL_NS_WIDGET   -I../../../dist/./include
-I../../../dist/include -I../../../../include -I/u/igb/mozilla/build/include
-I../../../dist/./public/jpeg -I../../../dist/./public/png
-I../../../dist/./public/zlib  -I../../../../widget/src/gtk/../xpwidgets
-I../../../../widget/src/gtk/../gtk -I../../../../widget/src/gtk/.
-I/usr/openwin/include -I/u/igb/mozilla/build/lib/glib/include
-I/u/igb/mozilla/build/include -I/usr/openwin/include
../../../../widget/src/gtk/nsComboBox.cpp
In file included from ../../../../widget/src/gtk/nsWidget.h:22,
                 from ../../../../widget/src/gtk/nsComboBox.h:22,
                 from ../../../../widget/src/gtk/nsComboBox.cpp:21:
../../../../widget/src/gtk/../xpwidgets/nsBaseWidget.h:123: conflicting return
type specified for virtual function `class nsISupports *
nsBaseWidget::Enumerator::Next()'
../../../dist/include/nsIEnumerator.h:44:   overriding definition as `unsigned
int nsIEnumerator::Next()'
make[3]: *** [nsComboBox.o] Error 1
make[3]: Leaving directory
`/u/igb/mozilla/mozilla/obj-sparc-sun-solaris2.6/widget/src/gtk'
make[2]: *** [libs] Error 2
make[2]: Leaving directory
`/u/igb/mozilla/mozilla/obj-sparc-sun-solaris2.6/widget/src'
make[1]: *** [libs] Error 2
make[1]: Leaving directory
`/u/igb/mozilla/mozilla/obj-sparc-sun-solaris2.6/widget'
make: *** [libs] Error 2
(Reporter)

Comment 1

20 years ago
*** Bug 1844 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
Version: 1998-03-31
(Reporter)

Comment 2

20 years ago
fixed later.  i have seen this particular build issue come and go before.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

20 years ago
It's still there.  Quite how I got a clean build yesterday I don't know.

Comment 4

20 years ago
do you still have this problem ?

-re
(Assignee)

Updated

20 years ago
Assignee: ramiro → mcafee
Status: REOPENED → NEW
Summary: Build Fails Latest Sources → Build Fails: conflicting return types in nsBaseWidget::Enumerator::Next()
(Assignee)

Updated

20 years ago
Resolution: FIXED → ---
(Assignee)

Comment 5

20 years ago
2.8.1 isn't ready for primetime on Solaris, can you go back
to 2.7.* or try egcs?  I'm using egcs 2.91.60 on Solaris 2.6,
it works pretty well so far.

Comment 6

20 years ago
Setting all current Open/Normal to M4.

Updated

20 years ago
QA Contact: 3819

Comment 7

20 years ago
Chris, what about this one also...
(Assignee)

Updated

20 years ago
Component: XFE → Build Config
Product: MozillaClassic → Browser
Version: 1998-03-31 → other
(Assignee)

Updated

20 years ago
Priority: P2 → P3

Comment 8

20 years ago
Is there some reason we'd hold m4 for this?  If not, we should retarget for
later.
(Assignee)

Updated

20 years ago
Target Milestone: M4 → M5
(Assignee)

Comment 9

20 years ago
m5
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
The code looks Ok to me, the main tinderboxes seem
to agree, marking fixed.  Please re-open if you are
still seeing this problem.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
marking verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.