Closed Bug 1843071 Opened 11 months ago Closed 11 months ago

Messages list do not refresh when deleting one

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 116
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: lepogam, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/115.0

Steps to reproduce:

Thunderbird 116.0b2 (64-bit) on MacOS 12.5 Monterey

In inbox (or any folder) delete a message using the "Delete" key

Actual results:

Message is actually deleted but not removed in the list (you can see the next message in the details) : the messages list is not refreshed, you need to go to another folder and come back to see it refreshed

Expected results:

Display should have been refreshed : current removed, and following messages scrolled up

There have been multiple reports of this in beta topicbox

Blocks: sn-msglist
Keywords: regression
Whiteboard: [Supernova3p]
See Also: → 1841423

I'm on 116.0b3 (64-bit) Windows 10.

It's gotten to the point where I'm now terrified of deleting messages as they don't go away and the focus bar stays where it is and no other message in the list can be selected until I click away from the folder and then back into it. Deleting messages is a one-by-one, click away, lick back process and I've got nearly a dozen active email accounts.

When you delete a message sometimes the message window shows the same message and sometimes it shows the next in line but the message list stays the same with the deleted message now in grey. If I click on the next message in the link it's not the NEXT but the one that should have been next that shows in the message window.

This started about 3 'upgrades' ago and has gotten progressively worse over time. When I downloaded b3 last night? I thought it was fixed but it's only gotten worse.

I saw where someone said they only had the problem with Gmail accounts but that blasted Microsoft thing the State makes me use is just as bad as are non-gmail pop and IMAP accounts. My newsfeed is also affected.

As I can't edit the above here's some more:

If I've a folder with a lot of messages and select all (this needs to be a button) and delete them, they disappear for all but two 'ghosts' in the message list but the messages still appear in the message window in their multi-select box thing.

(Also, and not related, if I'm deep in my folder list window and select Compact View (I need to switch it on and off as empty folders don't go away on their own) I end up at the top folder. This has been happening since the new interface came out. With the old, I'd perform that task and never leave the folder I was in - which is way more preferable than having to go dig for where I was.)

JmG, lepogam,
Does this reproduce with 116.0b4 ?

Flags: needinfo?(lepogam)
Flags: needinfo?(jeffisontheroad)

(In reply to Wayne Mery (:wsmwk) from comment #5)

JmG, lepogam,
Does this reproduce with 116.0b4 ?

Just upgraded this morning and so far.... it's pretty good.

When I get home later I'll have a folder with a few hundred messages so we'll find out for certain.

Thanks for the work on this.

J

Flags: needinfo?(jeffisontheroad)

Hours later, scores of emails gone through and deleted and it's working well. In fact, it's faster than it's been for the past 6 or 7 updates.

J

Hello, everything OK on 116.0b4,
Thanks a lot !

Flags: needinfo?(lepogam)
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.