nsBookmarksService::initDatasource doesn't

VERIFIED DUPLICATE of bug 183052

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 183052
16 years ago
14 years ago

People

(Reporter: bz, Assigned: timeless)

Tracking

({assertion})

Trunk
assertion

Firefox Tracking Flags

(Not tracked)

Details

This causes two assertions, one on startup, one on shutdown.  The problem is
that the RDFXMLDataSourceImpl destructor flushes the datasource, which asserts
that the uri of the datasource is non-null.  But in this case it is, since
RDFXMLDataSourceImpl::Init(const char* uri) never got called.... (oh, and it
looks like this fucks up the registration of the datasource with the rdf service
too...)
timeless volunteered to take this..
Assignee: ben → timeless

*** This bug has been marked as a duplicate of 183052 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.