Closed Bug 1843228 Opened 11 months ago Closed 7 months ago

Boxes are unexpectedly overlapped with a combination of CSS flexbox and CSS multi-column layout

Categories

(Core :: Layout: Flexbox, defect)

x86_64
Windows 11
defect

Tracking

()

RESOLVED DUPLICATE of bug 1744363
Tracking Status
firefox-esr102 --- wontfix
firefox-esr115 --- wontfix
firefox115 --- wontfix
firefox116 --- wontfix
firefox117 --- wontfix
firefox118 --- wontfix

People

(Reporter: yuki, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Boxes are unexpectedly overlapped with a combination of CSS flexbox, CSS multi-column layout, and possibly some more properties. Google Chrome renders same testcase without any visual error, so this can be a web compatibility issue.

Steps to reproduce

  1. Start Firefox with a clean profile.
  2. Load the attached testcase.
  3. Reload sometimes if you don't see any visual error.

Actual result

Some boxes are overlapped. (Please see more attached images.)

Expected result

Boxes are rendered with no overlapping.

Environment

  • Windows 11
  • Nightly 117.0a1 Build ID 20230712214907
  • Firefox 115.0.2 Build ID 20230710165010

This was originally reported to the issue tracker of a Firefox addon "Tree Style Tab".
https://github.com/piroor/treestyletab/issues/3361

STR is to load the testcase and reduce/increase the zoom from the zoom button in the hamburger menu. This bug depends on the total zoom level of the page. For my system, DPI=1.5 and 90% Zoom reproduced this bug.

Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=78ca58d04a9b107bc6989c3898852160a742e831&tochange=a77ca5bd6b7c49099c672e103771ca2bf077cc40

suspect: bug 1622935

See Also: → 1622935
Component: Layout: Columns → Layout: Flexbox

Set release status flags based on info from the regressing bug 1622935

:TYLin, since you are the author of the regressor, bug 1622935, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

This is probably similar to bug 1814057 or one of the bug that blocks bug 939897. A flex item can get taller if it is fragmented in multicol, but our current implementation doesn't recognize the potential growth of the height.

Blocks: 939897
Severity: -- → S3
Flags: needinfo?(aethanyc)

Set release status flags based on info from the regressing bug 1622935

The testcase in comment 0 looks good in print-preview in Nightly 122.0a1 (2023-12-06) after bug 1744363 is fixed. I don't see any content overlapping by using the STR in comment 3.

Status: NEW → RESOLVED
Closed: 7 months ago
Duplicate of bug: 1744363
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: