Closed Bug 1843445 Opened 8 months ago Closed 8 months ago

Crash in [@ mozilla::RestyleManager::ElementStateChanged]

Categories

(Core :: CSS Parsing and Computation, defect)

Unspecified
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1793410

People

(Reporter: mccr8, Unassigned)

References

Details

(Keywords: crash)

Crash report: https://crash-stats.mozilla.org/report/index/7f7b494d-2615-44fa-9beb-dfb140230712

Reason: SIGSEGV / SEGV_MAPERR

Top 10 frames of crashing thread:

0  libxul.so  MOZ_Crash  mfbt/Assertions.h:281
0  libxul.so  mozilla::RestyleManager::ElementStateChanged  layout/base/RestyleManager.cpp:3294
0  libxul.so  mozilla::PresShell::ElementStateChanged  layout/base/PresShell.cpp:4439
1  libxul.so  mozilla::dom::Document::ElementStateChanged  dom/base/Document.cpp:8254
2  libxul.so  mozilla::dom::Element::NotifyStateChange  dom/base/Element.cpp:369
3  libxul.so  mozilla::dom::HTMLTextAreaElement::OnValueChanged  dom/html/HTMLTextAreaElement.cpp
4  libxul.so  mozilla::TextControlElement::OnValueChanged  dom/html/TextControlElement.h:193
4  libxul.so  mozilla::TextControlState::SetValue  dom/html/TextControlState.cpp:2706
5  libxul.so  mozilla::TextControlState::SetValue  dom/html/TextControlState.h:284
5  libxul.so  mozilla::TextControlState::UnbindFromFrame  dom/html/TextControlState.cpp:2469

There have been a few recent fixes to this kind of crash it looks like, but it is still happening on m-c, so I thought I'd file a new bug.

Ah right, there's still an open bug on file.

Status: NEW → RESOLVED
Crash Signature: [@ mozilla::RestyleManager::ElementStateChanged]
Closed: 8 months ago
Duplicate of bug: 1793410
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.