Closed Bug 1843462 Opened 1 year ago Closed 1 year ago

Context menu delete scrolls message list to the top with smooth scrolling enabled (general.smoothScroll)

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 117

Tracking

(thunderbird_esr115+ fixed, thunderbird116 wontfix, thunderbird117 fixed)

RESOLVED FIXED
118 Branch
Tracking Status
thunderbird_esr115 + fixed
thunderbird116 --- wontfix
thunderbird117 --- fixed

People

(Reporter: sancus, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p] )

Attachments

(1 file)

STR:

  1. Be in traditional TB date sort order with new messages on the bottom(this is required).
  2. Right-click on a message and delete it.
  3. Notice that you have now scrolled all the way to the top.

This does not happen if you're using the keyboard shortcut.

Blocks: sn-msglist
Keywords: regression
Whiteboard: [Supernova3p]
See Also: → 1841423

Duplicate of bug 1835173?

(In reply to Francesco from comment #1)

Duplicate of bug 1835173?

No, this bug is different and still happens on Daily as of today.

Version: unspecified → Thunderbird 117
See Also: → 1844913
Depends on: 1835173
Flags: needinfo?(leftmostcat)

Can you check if this problem goes away with general.smoothScroll set to false? I can reproduce something similar, and it seems to be something to do with the smooth scrolling.

Flags: needinfo?(sancus)

Yeah, I can't reproduce this when smooth scrolling is disabled.

Flags: needinfo?(sancus)
Summary: Context menu delete scrolls message list to the top → Context menu delete scrolls message list to the top with smooth scrolling enabled
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(leftmostcat)

If invalidate is called, the TreeView should immediately stop adding buffer rows. And instead
of adding extra rows immediately after invalidation, it should wait to the end of the event loop
in case something else happens first.

Summary: Context menu delete scrolls message list to the top with smooth scrolling enabled → Context menu delete scrolls message list to the top with smooth scrolling enabled (general.smoothScroll)

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0ba753934546
Prevent filling of off-screen TreeView rows during invalidation. r=leftmostcat

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

That should at least make things better most of the time if not all of the time.

Target Milestone: --- → 118 Branch

Comment on attachment 9346174 [details]
Bug 1843462 - Prevent filling of off-screen TreeView rows during invalidation. r=leftmostcat

[Approval Request Comment]
Regression caused by (bug #): new message list
User impact if declined: list scrolls to strange places
Testing completed (on c-c, etc.): a week on c-c
Risk to taking this patch (and alternatives if risky): no

Attachment #9346174 - Flags: approval-comm-beta?

Comment on attachment 9346174 [details]
Bug 1843462 - Prevent filling of off-screen TreeView rows during invalidation. r=leftmostcat

[Triage Comment]
Approved for beta

Attachment #9346174 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9346174 [details]
Bug 1843462 - Prevent filling of off-screen TreeView rows during invalidation. r=leftmostcat

[Approval Request Comment]
Regression caused by (bug #): new message list
User impact if declined: list scrolls to strange places
Testing completed (on c-c, etc.): in beta 3
Risk to taking this patch (and alternatives if risky): no

Attachment #9346174 - Flags: approval-comm-esr115?

Comment on attachment 9346174 [details]
Bug 1843462 - Prevent filling of off-screen TreeView rows during invalidation. r=leftmostcat

[Triage Comment]
Approved for esr115

Attachment #9346174 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: