Closed Bug 1843887 Opened 10 months ago Closed 10 months ago

Unable to open URL with numerical link local IPv6 address containing a sope identifier formatted according to rfc6874

Categories

(Core :: Networking, defect, P3)

Firefox 115
defect

Tracking

()

RESOLVED DUPLICATE of bug 700999

People

(Reporter: Mario.Klebsch, Unassigned)

Details

(Whiteboard: [necko-triaged])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0

Steps to reproduce:

Enter 'http://[fe80::58bc:daff:fe86:ba71%2525]/' (whithout the quotes) in the address bar of firefox windows.

I have a system reachable as fe80::58bc:daff:fe86:ba71%25 on the command line and a web server running on port 80 on that system.

Note that the scope ID of the interface on windows happen to be 25, which is the same number as the '%' is escaped to '%25'. For this reason, the Address in the URL includes '%2525', while %25 is the scope identifier to be used e.g. with ping on the command line

Actual results:

The URL is passed as a search to google and 'https://www.google.com/search?client=firefox-b-d&q=http%3A%2F%2F%5Bfe80%3A%3A58bc%3Adaff%3Afe86%3Aba71%252525%5D' is opened

Expected results:

Firefox should connect fe80::58bc:daff:fe86:ba71%25 port 80 and get /.

The Bugbug bot thinks this bug should belong to the 'Firefox::Address Bar' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Address Bar

Calling new URL("http://[fe80::58bc:daff:fe86:ba71%2525]/") returns an error. We aren't sure if this is correct according to the spec.

In Chrome and Edge, the behavior is the same as in Firefox.

Moving this bug to the Network component for evaluation.

Component: Address Bar → Networking
Product: Firefox → Core

This may be "per-spec" for new URL(). (Note that there's no real spec for the URLBar, though entering a canonical URL string should work)

Severity: -- → S3
Flags: needinfo?(dotoole)
Priority: -- → P3
Whiteboard: [necko-triaged]
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Duplicate of bug: 700999
Flags: needinfo?(dotoole)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.