Closed Bug 1844036 Opened 1 year ago Closed 1 year ago

The PDF file is saved with blank pages and missing contents when adding images with different file types

Categories

(Firefox :: PDF Viewer, defect, P1)

Firefox 117
Desktop
All
defect

Tracking

()

VERIFIED FIXED
117 Branch
Tracking Status
firefox-esr102 --- disabled
firefox-esr115 --- disabled
firefox115 --- disabled
firefox116 --- disabled
firefox117 --- fixed

People

(Reporter: dlucaci, Assigned: calixte)

References

Details

Attachments

(2 files)

Attached video 2023-07-18_13h03_30.mp4

Found in

  • Nightly 117.0a1 (2023-07-17)

Affected versions

  • Nightly 117.0a1

Affected platforms

  • All

Steps to reproduce

  1. Open a PDF file in Firefox.
  2. Add Several images types to the PDF file.
  3. Click on the Print preview button.
  4. Print the PDF file by pressing the "Save" button.

Expected result

The PDF file is correctly saved with its content unchanged and with its images/content successfully displayed.

Actual result

The PDF file is saved with blank pages and missing contents.

Regression range
N/A

Notes
Sometimes the PDF files are saved with only the images missing, other times the whole pages are saved blank.

Severity: S3 → S2

An easy str:

  • open a pdf with at least two pages
  • add an image on the first page
  • copy and paste the image on the second page
  • add an other image (different of the first one) on the second page
  • print

When page 2 is printed we look for the annotation containing the bitmap originally on page 1:
https://github.com/mozilla/pdf.js/blob/43fc78899fea71cdadb4883aeeec51b849c29b3d/src/core/document.js#L452-L465
but we don't generate the images created for annotations on page 2.

Assignee: nobody → cdenizet
Status: NEW → ASSIGNED
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch
Flags: qe-verify+

Reproduced the issue on Nightly 117.0a1 (2023-07-18) following the STR, on Windows 11, Ubuntu 22 and macOS 13.
Verified it on Nightly 118.0a1 (2023-08-21) and 117.0 (with pref manually turned on, pref is off by default) builds on macOS 13, Windows 11 and Ubuntu 22, and can confirm that the issue is fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: