Incorrect image layout using DHTML

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Cédric Delayre, Assigned: Stuart Parmenter)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

In the HTML testcase given as an attachment mozilla_bug.zip, I place a picture
using DHTML, then a second picture that comes over the first one. The second
picture disappears while the first one is cut!

Reproducible: Always

Steps to Reproduce:
1.click on the animation's button
2.wait the first picture to expand
3.click another time on the animation's button

Actual Results:  
the second picture is moving over the first one, then it disappears while the
first picture is cut!

Expected Results:  
the second picture is moving over the first one. It should be placed at the
right side of the first picture like Internet Explorer 5.0 does.
(Reporter)

Comment 1

16 years ago
Created attachment 108732 [details]
HTML testcase
Attachment #108732 - Attachment mime type: application/octet-stream → application/zip

Updated

16 years ago
Keywords: testcase

Comment 2

16 years ago
-> Views
Even without images (ie. replacing the img src with a bunch of text), the one
div erases the other div's stuff.
Component: Image: Layout → Views

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
roc, can you help here?
Would you mind attaching a testcase in raw HTML?
(Reporter)

Comment 5

16 years ago
sorry, I cannot attach a testcase in raw HTML. In my current project, I use
DHTML and JavaScript to realize an animation when a user pushes a button.
I don't have any idea to do the same thing using HTML only.

I send to you my best wishes for 2003,
Cedric Delayre.

Comment 6

16 years ago
Unzipped the html testcase and it works fine. Dont see what is described in
comment 0.
Using build 2003010108, Windows XP

Comment 7

16 years ago
marking wfm ?
(Reporter)

Comment 8

16 years ago
Well, this bug seems to be fixed in the release
Mozilla 1.3b, Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b) Gecko/20030210
build #2003021008

good job guys! :-)

Comment 9

16 years ago
Marking WFM, after reporters and others comments
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.