transparency of png-images (probably gif, too) is ignored while printing

VERIFIED DUPLICATE of bug 141656

Status

()

Core
Printing: Output
VERIFIED DUPLICATE of bug 141656
15 years ago
15 years ago

People

(Reporter: joern.huxhorn, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

The transparent pixels of png's are always white instead of the color of the
underlying background. The images I used are palette-based.

Reproducible: Always

Steps to Reproduce:
<div class="example">
<img src="imgs/someImage.png" alt="someDescription" />
</div>

with the following style-information:
div.example
{
	clear: both;
	float: right;
	margin-left: 10px;
	margin-top: 10px;
	margin-right: 0px;
	margin-bottom: 10px;
	padding-top: 0em;
	padding-right: 1em;
	padding-left: 1em;
	padding-bottom: 1em;
	border: solid medium;
	color: #000000;
	background-color: #dddddd;
}

Actual Results:  
The div itself has a gray background but the background of the image is white
instead (probably just in my case... could be that some other color may be
choosen for different png's).

Expected Results:  
The transparent pixels should have the same color as the background of the div
like in the ordinary view of the page. It's only wrong while printing.

A workaround would be to change the background-color of the div for media="print"

Comment 1

15 years ago
-->
Assignee: rods → dcone

Comment 2

15 years ago
I also have similar problems with this when printing transparent GIFs. The
background image (CSS-rendered background image) shows up onscreen and in the
Print Preview, but not on the printed hard copy.

Go to http://www.public.asu.edu/~aubjr/one/temp_a.html and print the template
(including background images) for a sample of this problem.

*** This bug has been marked as a duplicate of 141656 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 4

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.