Closed Bug 18446 Opened 20 years ago Closed 20 years ago

Esc key does not dismiss the dialog

Categories

(SeaMonkey :: General, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: xiaotong, Assigned: akkzilla)

References

Details

In dialog (e.g. Open Web Location), using Esc key does not dismiss the dialog.
This is also accessibility issue. No way to dismiss the dialog using keyboard
only.
Assign it to don to take a look.
Assignee: don → danm
dialogs.  danm, can you look at this?
Assignee: danm → akkana
Event handling.

  Ironically, and it is a little bit that, this is working on this morning's NT build, but not on
any other platform. I haven't done a complete, multi-platform analysis of this problem, but
I do know that the reason it no longer works on unix is because unix/platformDialogOverlay.xul,
rev 1.6, changed the id of the dialog keyset from "keyset" to "unixdialogkeyset". If you really
want to do that, you should also teach the corresponding C code to look for both IDs.
Dialog default keys become operational if you change it back to "keyset".
  Assigning to the person who made that change for further consideration.
Status: NEW → ASSIGNED
Target Milestone: M13
In fact, I was just asking someone about that this morning, wondering whether in
the new re-re-redesigned key bindings world it should be changed to "keyset" to
match the windows version of that file.

I'll make the change, assuming I can get permission to check this in.
*** Bug 18842 has been marked as a duplicate of this bug. ***
Quoting from bug 17569 "Pressing <ENTER> key in Dialogues should equate to OK
button":
  >----- Additional Comments From sdagley@netscape.com  1999-12-22 16:43 -----
  >Hangas asked for key behavior in dialog bugs to be sent his way...
But... the Status Whiteboard for that bug says "[PDT-]RN may be fixed with
other dialog fixes" - and it seems that it might be.
Adding Hangas to the Cc: list.

It would be nice if this bug and that one could be fixed and verified
together... they really do make a set in users' expectations.

Confirmed that ESC is dismissing all dialogs on the File Menu on NT with
1999-12-23-08-M13.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This was fixed before christmas, I just forgot to close out the bug.
Status: RESOLVED → VERIFIED
VERIFIED fixed on all platforms as of 20000111 builds
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.