Mail filter window shows hourglass upon pressing "New" or "Edit"

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: TablaFinger, Assigned: naving)

Tracking

({hang})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

I currently have 6 mail filters active, they worked fine so far. Today I tried
to add a new one. Upon pressing "New" the sand clock is shown. The same happens
to me upon pressing "Edit" or double clicking a rule. I am no longer able to
switch to other instances of Mozilla (e.g. Browser). Pressing alt-ctrl-del gives
me the list of applications, it says "Message filters is not responding" (my
message is in German). Killing the no longer responding task kills all of Mozilla. 

Reproducible: Always

Steps to Reproduce:
1. Open the Message Filters dialog
2. Double click a rule or press "New"
3. That´s it

Actual Results:  
The sand clock is shown, all of Mozilla is no longer usable.

Expected Results:  
Open the rule for editing

No error message, no problem to restart Mozilla again

Updated

16 years ago
Keywords: hang

Comment 1

16 years ago
WFM - 2003013108
Reporter: Are you still seeing this problem with a recent build? Could you try
locating xul.mfl, deleting it (it will be automatically regenerated when you
next start mozilla) and reporting if this fixes the problem?

Comment 2

16 years ago
I have many filters--perhaps 100+.  Has been working fine.  Don't know what
changed.  Filters still operate.  Can't use any of the "management" buttons
except to display the log.

Updated

16 years ago
Summary: Mail filter window shows sand clock upon pressing "New" or "Edit" → Mail filter window shows hourglass upon pressing "New" or "Edit"

Comment 3

16 years ago
Tabla Finger, Brainz0: did either of you try the suggestion in comment 1?
Are you still having this problem?

Comment 4

16 years ago
No response for the past four months. Marking WFM.
Reporter: if you can reproduce this with a recent build (Mozilla 1.4 or higher),
with the suggested fix from comment 1 not having any effect, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.