Exiting address book also exits browswer

RESOLVED INVALID

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Steven Mask, Assigned: racham)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021209
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021209

When exiting the address book from the 'File' pull-down menu using the 'Exit'
option, the browswer window also gets closed

Reproducible: Always

Steps to Reproduce:
1.Open address book
2.Exit using 'Exit' in 'File' pull-down menu
3.

Actual Results:  
The address book and the browswer window closed

Expected Results:  
Only closed the address book window
There are bugs filed on this already, all marked INVALID or WONTFIX....
Summary: Exiting address book also exits browswer → Exiting address book also exits browser
Whiteboard: DUPEME
File|close will do what you want.

File|exit will close the whole application 

-> invalid (no bug)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Summary: Exiting address book also exits browser → Exiting address book also exits browswer
Whiteboard: DUPEME

Comment 3

15 years ago
*** Bug 219750 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 4

12 years ago
howdy y'all,

[1] my tb info ...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060516 Thunderbird/1.5.0.4 - Build ID: 2006051612

[2] this seems to be wrong behavior.
the file/exit command seems like should do just what the "X" button on the window does. if that is not correct, then the command ought not to be there.

[3] this is inconsistent behavior.
the file/exit command in extensions manager does not close tbird. 
the file/exit command in theme manager does not close tbird.

the file/exit command in address book manager DOES close tbird.
the file/exit command in a msg window [write/reply/forward] DOES close tbird.

i know the last two such windows can be opened alone. still, it doesn't seem right that three different windows can all be open and all can close the app - even when one only intended to close that one window.

[4] the result is very, very unexpected.
look at the number of times this bug/rfe has been filed ... 

- Entire application exits when selecting File-->Exit in address book
https://bugzilla.mozilla.org/show_bug.cgi?id=219750

- Address book File-exit menu item confusing
https://bugzilla.mozilla.org/show_bug.cgi?id=253719

- The entire Thunderbird application closes down when closing the Address Book screen using the File~Exit option
https://bugzilla.mozilla.org/show_bug.cgi?id=327533

those are just the ones that are linked to this series of bug reports. i am quite certain other folks have been driven to distraction by this but haven't had the courage to file yet another request for a change.

[5] perhaps a change in the menus would do the job?
- if the main window is open, then DO NOT allow other windows to show the file/exit command. show only file/close
- if more than one of the "exit tbird"-capable windows is open, then allow only one of them to close the app. 

take care,
lee

Comment 5

12 years ago
I find it hard to believe that the Mozilla developers find the existing
behavior (pop up the Address Book dialog, let the user believe they are
running a separate application by including a Quit menu item, then exit
Thunderbird when the person goes to quit the Address Book "application")
is good user interface design.  I've been using Thunderbird for perhaps
a week now and I've been bitten by this problem several times already.
Address Book is *not* a standalone application.  Don't give it a Quit
menu item.  It's as simple as that.

It's not an invalid request.  It has apparently been reported over and
over and over again.  That should give the developers some clue that
they have it wrong, not the users.  It is bad user interface design.

Skip Montanaro
You need to log in before you can comment on or make changes to this bug.