Closed Bug 1845367 Opened 10 months ago Closed 10 months ago

Mach not finding redo on repackage-deb-linux tasks

Categories

(Release Engineering :: General, defect, P2)

Desktop
Linux

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1845272

People

(Reporter: gabriel, Assigned: gabriel)

References

(Blocks 1 open bug)

Details

We aren't getting the latest Nightlies because of an error in the tar ➡️ deb repackage step.

[task 2023-07-25T11:59:37.605Z] 11:59:37     INFO -  Error running mach:
[task 2023-07-25T11:59:37.605Z] 11:59:37     INFO -      mach --log-no-times repackage deb --arch x86_64 --templates browser/installer/linux/app/debian --version 117.0a1 --build-number 1 --release-product None --release-type nightly --input /builds/worker/fetches/target.tar.bz2 --output /builds/worker/workspace/outputs/target.deb
[task 2023-07-25T11:59:37.605Z] 11:59:37     INFO -  The error occurred in code that was called by the mach command. This is either
[task 2023-07-25T11:59:37.605Z] 11:59:37     INFO -  a bug in the called code itself or in the way that mach is calling it.
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -  You can invoke ``./mach busted`` to check if this issue is already on file. If it
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -  isn't, please use ``./mach busted file repackage`` to report it. If ``./mach busted`` is
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -  misbehaving, you can also inspect the dependencies of bug 1543241.
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -  If filing a bug, please include the full output of mach, including this error
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -  message.
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -  The details of the failure are as follows:
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -  ModuleNotFoundError: No module named 'redo'
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -    File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/mach_commands.py", line 2330, in repackage_deb
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -      from mozbuild.repackaging.deb import repackage_deb
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -    File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/repackaging/deb.py", line 22, in <module>
[task 2023-07-25T11:59:37.606Z] 11:59:37     INFO -      from redo import retry
[task 2023-07-25T11:59:37.644Z] 11:59:37     INFO - Return code: 1
[task 2023-07-25T11:59:37.645Z] 11:59:37    ERROR - 1 not in success codes: [0]
[task 2023-07-25T11:59:37.645Z] 11:59:37  WARNING - setting return code to 2
[task 2023-07-25T11:59:37.645Z] 11:59:37    FATAL - Halting on failure while running ['/builds/worker/.mozbuild/srcdirs/gecko-8a5b87fe5d69/_virtualenvs/common/bin/python', 'mach', '--log-no-times', 'repackage', 'deb', '--arch', 'x86_64', '--templates', 'browser/installer/linux/app/debian', '--version', '117.0a1', '--build-number', '1', '--release-product', 'None', '--release-type', 'nightly', '--input', '/builds/worker/fetches/target.tar.bz2', '--output', '/builds/worker/workspace/outputs/target.deb']
Assignee: nobody → gabriel
Status: NEW → ASSIGNED

On more recent tasks the module not found is fluent.

[task 2023-07-27T10:13:53.707Z] 10:13:53     INFO -  ModuleNotFoundError: No module named 'fluent.runtime'
[task 2023-07-27T10:13:53.707Z] 10:13:53     INFO -    File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/mach_commands.py", line 2328, in repackage_deb
[task 2023-07-27T10:13:53.707Z] 10:13:53     INFO -      from fluent.runtime.fallback import FluentLocalization, FluentResourceLoader
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Duplicate of bug: 1845272
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.